e299fe0cce8306d747c2e729f17ed0b3d2a05233
[reactos.git] / dll / win32 / bcrypt / bcrypt.spec
1 @ stub BCryptAddContextFunction
2 @ stub BCryptAddContextFunctionProvider
3 @ stdcall BCryptCloseAlgorithmProvider(ptr long)
4 @ stub BCryptConfigureContext
5 @ stub BCryptConfigureContextFunction
6 @ stub BCryptCreateContext
7 @ stdcall BCryptCreateHash(ptr ptr ptr long ptr long long)
8 @ stub BCryptDecrypt
9 @ stub BCryptDeleteContext
10 @ stub BCryptDeriveKey
11 @ stdcall BCryptDestroyHash(ptr)
12 @ stub BCryptDestroyKey
13 @ stub BCryptDestroySecret
14 @ stub BCryptDuplicateHash
15 @ stub BCryptDuplicateKey
16 @ stub BCryptEncrypt
17 @ stdcall BCryptEnumAlgorithms(long ptr ptr long)
18 @ stub BCryptEnumContextFunctionProviders
19 @ stub BCryptEnumContextFunctions
20 @ stub BCryptEnumContexts
21 @ stub BCryptEnumProviders
22 @ stub BCryptEnumRegisteredProviders
23 @ stub BCryptExportKey
24 @ stub BCryptFinalizeKeyPair
25 @ stdcall BCryptFinishHash(ptr ptr long long)
26 @ stub BCryptFreeBuffer
27 @ stdcall BCryptGenRandom(ptr ptr long long)
28 @ stub BCryptGenerateKeyPair
29 @ stub BCryptGenerateSymmetricKey
30 @ stdcall BCryptGetFipsAlgorithmMode(ptr)
31 @ stdcall BCryptGetProperty(ptr wstr ptr long ptr long)
32 @ stdcall BCryptHash(ptr ptr long ptr long ptr long)
33 @ stdcall BCryptHashData(ptr ptr long long)
34 @ stub BCryptImportKey
35 @ stub BCryptImportKeyPair
36 @ stdcall BCryptOpenAlgorithmProvider(ptr wstr wstr long)
37 @ stub BCryptQueryContextConfiguration
38 @ stub BCryptQueryContextFunctionConfiguration
39 @ stub BCryptQueryContextFunctionProperty
40 @ stub BCryptQueryProviderRegistration
41 @ stub BCryptRegisterConfigChangeNotify
42 @ stub BCryptRegisterProvider
43 @ stub BCryptRemoveContextFunction
44 @ stub BCryptRemoveContextFunctionProvider
45 @ stub BCryptResolveProviders
46 @ stub BCryptSecretAgreement
47 @ stub BCryptSetAuditingInterface
48 @ stub BCryptSetContextFunctionProperty
49 @ stub BCryptSetProperty
50 @ stub BCryptSignHash
51 @ stub BCryptUnregisterConfigChangeNotify
52 @ stub BCryptUnregisterProvider
53 @ stub BCryptVerifySignature
54 @ stub GetAsymmetricEncryptionInterface
55 @ stub GetCipherInterface
56 @ stub GetHashInterface
57 @ stub GetRngInterface
58 @ stub GetSecretAgreementInterface
59 @ stub GetSignatureInterface