[IPHLPAPI] Preserve decoration in exported symbols
[reactos.git] / dll / win32 / iphlpapi / iphlpapi.spec
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpExTable2FromStack( ptr long long long long long )
8 @ stdcall AllocateAndGetTcpExTableFromStack( ptr long long long long )
9 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
10 @ stdcall AllocateAndGetUdpExTable2FromStack( ptr long long long long long )
11 @ stdcall AllocateAndGetUdpExTableFromStack( ptr long long long long )
12 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
13 @ stdcall CancelIPChangeNotify(ptr)
14 @ stub CancelSecurityHealthChangeNotify
15 @ stdcall CreateIpForwardEntry( ptr )
16 @ stdcall CreateIpNetEntry( ptr )
17 @ stdcall CreateProxyArpEntry( long long long )
18 @ stdcall DeleteIPAddress( long )
19 @ stdcall DeleteIpForwardEntry( ptr )
20 @ stdcall DeleteIpNetEntry( ptr )
21 @ stdcall DeleteProxyArpEntry( long long long )
22 @ stdcall DisableMediaSense(ptr ptr)
23 @ stdcall EnableRouter( ptr ptr )
24 @ stdcall FlushIpNetTable( long )
25 @ stub FlushIpNetTableFromStack
26 @ stdcall GetAdapterIndex( wstr ptr )
27 @ stdcall GetAdapterOrderMap()
28 @ stdcall GetAdaptersAddresses( long long ptr ptr ptr )
29 @ stdcall GetAdaptersInfo( ptr ptr )
30 @ stdcall GetBestInterface( long ptr )
31 @ stdcall GetBestInterfaceEx(ptr ptr)
32 @ stub GetBestInterfaceFromStack
33 @ stdcall GetBestRoute( long long long )
34 @ stub GetBestRouteFromStack
35 @ stdcall GetExtendedTcpTable( ptr ptr long long long long )
36 @ stdcall GetExtendedUdpTable( ptr ptr long long long long )
37 @ stdcall GetFriendlyIfIndex( long )
38 @ stdcall GetIcmpStatistics( ptr )
39 @ stdcall GetIcmpStatisticsEx(ptr long)
40 @ stub GetIcmpStatsFromStack
41 @ stub GetIcmpStatsFromStackEx
42 @ stdcall GetIfEntry( ptr )
43 @ stub GetIfEntryFromStack
44 @ stdcall GetIfTable( ptr ptr long )
45 @ stub GetIfTableFromStack
46 @ stub GetIgmpList
47 @ stdcall GetInterfaceInfo( ptr ptr )
48 @ stdcall GetIpAddrTable( ptr ptr long )
49 @ stub GetIpAddrTableFromStack
50 @ stdcall GetIpErrorString(long ptr ptr)
51 @ stdcall GetIpForwardTable( ptr ptr long )
52 @ stub GetIpForwardTableFromStack
53 @ stdcall GetIpNetTable( ptr ptr long )
54 @ stub GetIpNetTableFromStack
55 @ stdcall GetIpStatistics( ptr )
56 @ stdcall GetIpStatisticsEx(ptr long)
57 @ stub GetIpStatsFromStack
58 @ stub GetIpStatsFromStackEx
59 @ stdcall GetNetworkParams( ptr ptr )
60 @ stdcall GetNumberOfInterfaces( ptr )
61 @ stub GetOwnerModuleFromTcp6Entry
62 @ stdcall GetOwnerModuleFromTcpEntry ( ptr long ptr ptr )
63 @ stub GetOwnerModuleFromUdp6Entry
64 @ stdcall GetOwnerModuleFromUdpEntry ( ptr long ptr ptr )
65 @ stdcall GetPerAdapterInfo( long ptr ptr )
66 @ stdcall GetRTTAndHopCount( long ptr long ptr )
67 @ stub GetTcpExTable2FromStack
68 @ stdcall GetTcpStatistics( ptr )
69 @ stdcall GetTcpStatisticsEx(ptr long)
70 @ stub GetTcpStatsFromStack
71 @ stub GetTcpStatsFromStackEx
72 @ stdcall GetTcpTable( ptr ptr long )
73 @ stub GetTcpTableFromStack
74 @ stub GetUdpExTable2FromStack
75 @ stdcall GetUdpStatistics( ptr )
76 @ stdcall GetUdpStatisticsEx(ptr long)
77 @ stub GetUdpStatsFromStack
78 @ stub GetUdpStatsFromStackEx
79 @ stdcall GetUdpTable( ptr ptr long )
80 @ stub GetUdpTableFromStack
81 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
82 @ stdcall Icmp6CreateFile()
83 @ stdcall -stub Icmp6ParseReplies(ptr long)
84 @ stdcall Icmp6SendEcho2(ptr ptr ptr ptr ptr ptr ptr long ptr ptr long long)
85 @ stdcall IcmpCloseHandle(ptr)
86 @ stdcall IcmpCreateFile()
87 @ stdcall -stub IcmpParseReplies(ptr long)
88 @ stdcall IcmpSendEcho2(ptr ptr ptr ptr long ptr long ptr ptr long long)
89 @ stdcall IcmpSendEcho(ptr long ptr long ptr ptr long long)
90 @ stub InternalCreateIpForwardEntry
91 @ stub InternalCreateIpNetEntry
92 @ stub InternalDeleteIpForwardEntry
93 @ stub InternalDeleteIpNetEntry
94 @ stub InternalGetIfTable
95 @ stub InternalGetIpAddrTable
96 @ stub InternalGetIpForwardTable
97 @ stub InternalGetIpNetTable
98 @ stub InternalGetTcpTable
99 @ stub InternalGetUdpTable
100 @ stub InternalSetIfEntry
101 @ stub InternalSetIpForwardEntry
102 @ stub InternalSetIpNetEntry
103 @ stub InternalSetIpStats
104 @ stub InternalSetTcpEntry
105 @ stdcall IpReleaseAddress( ptr )
106 @ stdcall IpRenewAddress( ptr )
107 @ stub IsLocalAddress
108 @ stub NTPTimeToNTFileTime
109 @ stub NTTimeToNTPTime
110 @ stub NhGetGuidFromInterfaceName
111 @ stdcall NhGetInterfaceNameFromDeviceGuid(ptr ptr ptr long long)
112 @ stdcall NhGetInterfaceNameFromGuid(ptr ptr ptr long long)
113 @ stdcall NhpAllocateAndGetInterfaceInfoFromStack(ptr ptr long ptr long)
114 @ stub NhpGetInterfaceIndexFromStack
115 @ stdcall NotifyAddrChange( ptr ptr )
116 @ stdcall NotifyRouteChange( ptr ptr )
117 @ stub NotifyRouteChangeEx
118 @ stub NotifySecurityHealthChange
119 @ stdcall RestoreMediaSense(ptr ptr)
120 @ stdcall SendARP(long long ptr ptr)
121 @ stub SetAdapterIpAddress
122 @ stub SetBlockRoutes
123 @ stdcall SetIfEntry( ptr )
124 @ stub SetIfEntryToStack
125 @ stdcall SetIpForwardEntry( ptr )
126 @ stdcall SetIpForwardEntryToStack( ptr )
127 @ stub SetIpMultihopRouteEntryToStack
128 @ stdcall SetIpNetEntry( ptr )
129 @ stub SetIpNetEntryToStack
130 @ stub SetIpRouteEntryToStack
131 @ stdcall SetIpStatistics( ptr )
132 @ stub SetIpStatsToStack
133 @ stdcall SetIpTTL( long )
134 @ stub SetProxyArpEntryToStack
135 @ stub SetRouteWithRef
136 @ stdcall SetTcpEntry( ptr )
137 @ stub SetTcpEntryToStack
138 @ stdcall UnenableRouter( ptr ptr )
139
140 # These are actually stubs, but we need to forward them to preserve the decoration.
141 @ stdcall -arch=i386 _PfAddFiltersToInterface@24() _PfAddFiltersToInterface@24
142 @ stdcall -arch=i386 _PfAddGlobalFilterToInterface@8() _PfAddGlobalFilterToInterface@8
143 @ stdcall -arch=i386 _PfBindInterfaceToIPAddress@12() _PfBindInterfaceToIPAddress@12
144 @ stdcall -arch=i386 _PfBindInterfaceToIndex@16() _PfBindInterfaceToIndex@16
145 @ stdcall -arch=i386 _PfCreateInterface@24() _PfCreateInterface@24
146 @ stdcall -arch=i386 _PfDeleteInterface@4() _PfDeleteInterface@4
147 @ stdcall -arch=i386 _PfDeleteLog@0() _PfDeleteLog@0
148 @ stdcall -arch=i386 _PfGetInterfaceStatistics@16() _PfGetInterfaceStatistics@16
149 @ stdcall -arch=i386 _PfMakeLog@4() _PfMakeLog@4
150 @ stdcall -arch=i386 _PfRebindFilters@8() _PfRebindFilters@8
151 @ stdcall -arch=i386 _PfRemoveFilterHandles@12() _PfRemoveFilterHandles@12
152 @ stdcall -arch=i386 _PfRemoveFiltersFromInterface@20() _PfRemoveFiltersFromInterface@20
153 @ stdcall -arch=i386 _PfRemoveGlobalFilterFromInterface@8() _PfRemoveGlobalFilterFromInterface@8
154 @ stdcall -arch=i386 _PfSetLogBuffer@28() _PfSetLogBuffer@28
155 @ stdcall -arch=i386 _PfTestPacket@20() _PfTestPacket@20
156 @ stdcall -arch=i386 _PfUnBindInterface@4() _PfUnBindInterface@4
157
158 # x64 does not use decoration in these names
159 @ stdcall -arch=x86_64 _PfAddFiltersToInterface@24()
160 @ stdcall -arch=x86_64 _PfAddGlobalFilterToInterface@8()
161 @ stdcall -arch=x86_64 _PfBindInterfaceToIPAddress@12()
162 @ stdcall -arch=x86_64 _PfBindInterfaceToIndex@16()
163 @ stdcall -arch=x86_64 _PfCreateInterface@24()
164 @ stdcall -arch=x86_64 _PfDeleteInterface@4()
165 @ stdcall -arch=x86_64 _PfDeleteLog@0()
166 @ stdcall -arch=x86_64 _PfGetInterfaceStatistics@16()
167 @ stdcall -arch=x86_64 _PfMakeLog@4()
168 @ stdcall -arch=x86_64 _PfRebindFilters@8()
169 @ stdcall -arch=x86_64 _PfRemoveFilterHandles@12()
170 @ stdcall -arch=x86_64 _PfRemoveFiltersFromInterface@20()
171 @ stdcall -arch=x86_64 _PfRemoveGlobalFilterFromInterface@8()
172 @ stdcall -arch=x86_64 _PfSetLogBuffer@28()
173 @ stdcall -arch=x86_64 _PfTestPacket@20()
174 @ stdcall -arch=x86_64 _PfUnBindInterface@4()
175
176 @ stub do_echo_rep
177 @ stub do_echo_req
178 @ stub register_icmp