Visual C++ backend for rbuild (for now just a hacked mingw backend) and related compi...
[reactos.git] / dll / win32 / iphlpapi / iphlpapi.spec
1 1 stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
9 @ stdcall CreateIpForwardEntry( ptr )
10 @ stdcall CreateIpNetEntry( ptr )
11 @ stdcall CreateProxyArpEntry( long long long )
12 @ stdcall DeleteIPAddress( long )
13 @ stdcall DeleteIpForwardEntry( ptr )
14 @ stdcall DeleteIpNetEntry( ptr )
15 @ stdcall DeleteProxyArpEntry( long long long )
16 @ stdcall EnableRouter( ptr ptr )
17 @ stdcall FlushIpNetTable( long )
18 @ stub FlushIpNetTableFromStack
19 @ stdcall GetAdapterIndex( wstr ptr )
20 @ stub GetAdapterOrderMap
21 @ stdcall GetAdaptersInfo( ptr ptr )
22 @ stdcall GetBestInterface( long ptr )
23 @ stub GetBestInterfaceFromStack
24 @ stdcall GetBestRoute( long long long )
25 @ stub GetBestRouteFromStack
26 @ stdcall GetFriendlyIfIndex( long )
27 @ stdcall GetIcmpStatistics( ptr )
28 @ stub GetIcmpStatsFromStack
29 @ stdcall GetIfEntry( ptr )
30 @ stub GetIfEntryFromStack
31 @ stdcall GetIfTable( ptr ptr long )
32 @ stub GetIfTableFromStack
33 @ stub GetIgmpList
34 @ stdcall GetInterfaceInfo( ptr ptr )
35 @ stdcall GetIpAddrTable( ptr ptr long )
36 @ stub GetIpAddrTableFromStack
37 @ stdcall GetIpForwardTable( ptr ptr long )
38 @ stub GetIpForwardTableFromStack
39 @ stdcall GetIpNetTable( ptr ptr long )
40 @ stub GetIpNetTableFromStack
41 @ stdcall GetIpStatistics( ptr )
42 @ stub GetIpStatsFromStack
43 @ stdcall GetNetworkParams( ptr ptr )
44 @ stdcall GetNumberOfInterfaces( ptr )
45 @ stdcall GetPerAdapterInfo( long ptr ptr )
46 @ stdcall GetRTTAndHopCount( long ptr long ptr )
47 @ stdcall GetTcpStatistics( ptr )
48 @ stub GetTcpStatsFromStack
49 @ stdcall GetTcpTable( ptr ptr long )
50 @ stub GetTcpTableFromStack
51 @ stdcall GetUdpStatistics( ptr )
52 @ stub GetUdpStatsFromStack
53 @ stdcall GetUdpTable( ptr ptr long )
54 @ stub GetUdpTableFromStack
55 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
56 @ stub InternalCreateIpForwardEntry
57 @ stub InternalCreateIpNetEntry
58 @ stub InternalDeleteIpForwardEntry
59 @ stub InternalDeleteIpNetEntry
60 @ stub InternalGetIfTable
61 @ stub InternalGetIpAddrTable
62 @ stub InternalGetIpForwardTable
63 @ stub InternalGetIpNetTable
64 @ stub InternalGetTcpTable
65 @ stub InternalGetUdpTable
66 @ stub InternalSetIfEntry
67 @ stub InternalSetIpForwardEntry
68 @ stub InternalSetIpNetEntry
69 @ stub InternalSetIpStats
70 @ stub InternalSetTcpEntry
71 @ stdcall IpReleaseAddress( ptr )
72 @ stdcall IpRenewAddress( ptr )
73 @ stub IsLocalAddress
74 @ stub NTPTimeToNTFileTime
75 @ stub NTTimeToNTPTime
76 @ stub NhGetGuidFromInterfaceName
77 @ stub NhGetInterfaceNameFromGuid
78 @ stub NhpAllocateAndGetInterfaceInfoFromStack
79 @ stub NhpGetInterfaceIndexFromStack
80 @ stdcall NotifyAddrChange( ptr ptr )
81 @ stdcall NotifyRouteChange( ptr ptr )
82 @ stub NotifyRouteChangeEx
83 @ stub _PfAddFiltersToInterface@24
84 @ stub _PfAddGlobalFilterToInterface@8
85 @ stub _PfBindInterfaceToIPAddress@12
86 @ stub _PfBindInterfaceToIndex@16
87 @ stub _PfCreateInterface@24
88 @ stub _PfDeleteInterface@4
89 @ stub _PfDeleteLog@0
90 @ stub _PfGetInterfaceStatistics@16
91 @ stub _PfMakeLog@4
92 @ stub _PfRebindFilters@8
93 @ stub _PfRemoveFilterHandles@12
94 @ stub _PfRemoveFiltersFromInterface@20
95 @ stub _PfRemoveGlobalFilterFromInterface@8
96 @ stub _PfSetLogBuffer@28
97 @ stub _PfTestPacket@20
98 @ stub _PfUnBindInterface@4
99 @ stub SetAdapterIpAddress
100 @ stub SetBlockRoutes
101 @ stdcall SetIfEntry( ptr )
102 @ stub SetIfEntryToStack
103 @ stdcall SetIpForwardEntry( ptr )
104 @ stub SetIpForwardEntryToStack
105 @ stub SetIpMultihopRouteEntryToStack
106 @ stdcall SetIpNetEntry( ptr )
107 @ stub SetIpNetEntryToStack
108 @ stub SetIpRouteEntryToStack
109 110 stdcall SetIpStatistics( ptr )
110 @ stub SetIpStatsToStack
111 112 stdcall SetIpTTL( long )
112 @ stub SetProxyArpEntryToStack
113 @ stub SetRouteWithRef
114 @ stdcall SetTcpEntry( ptr )
115 @ stub SetTcpEntryToStack
116 99 stdcall SendARP( long long ptr ptr )
117 117 stdcall UnenableRouter( ptr ptr )