Revert 45697:
[reactos.git] / lib / 3rdparty / libxml2 / libxml2.spec
1 Summary: Library providing XML and HTML support
2 Name: libxml2
3 Version: 2.7.6
4 Release: 1
5 License: MIT
6 Group: Development/Libraries
7 Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9 BuildRequires: python python-devel zlib-devel pkgconfig
10 URL: http://xmlsoft.org/
11
12 %description
13 This library allows to manipulate XML files. It includes support
14 to read, modify and write XML and HTML files. There is DTDs support
15 this includes parsing and validation even with complex DtDs, either
16 at parse time or later once the document has been modified. The output
17 can be a simple SAX stream or and in-memory DOM like representations.
18 In this case one can use the built-in XPath and XPointer implementation
19 to select subnodes or ranges. A flexible Input/Output mechanism is
20 available, with existing HTTP and FTP modules and combined to an
21 URI library.
22
23 %package devel
24 Summary: Libraries, includes, etc. to develop XML and HTML applications
25 Group: Development/Libraries
26 Requires: libxml2 = %{version}-%{release}
27 Requires: zlib-devel
28 Requires: pkgconfig
29
30 %description devel
31 Libraries, include files, etc you can use to develop XML applications.
32 This library allows to manipulate XML files. It includes support
33 to read, modify and write XML and HTML files. There is DTDs support
34 this includes parsing and validation even with complex DtDs, either
35 at parse time or later once the document has been modified. The output
36 can be a simple SAX stream or and in-memory DOM like representations.
37 In this case one can use the built-in XPath and XPointer implementation
38 to select subnodes or ranges. A flexible Input/Output mechanism is
39 available, with existing HTTP and FTP modules and combined to an
40 URI library.
41
42 %package python
43 Summary: Python bindings for the libxml2 library
44 Group: Development/Libraries
45 Requires: libxml2 = %{version}-%{release}
46 Requires: python
47
48 %description python
49 The libxml2-python package contains a module that permits applications
50 written in the Python programming language to use the interface
51 supplied by the libxml2 library to manipulate XML files.
52
53 This library allows to manipulate XML files. It includes support
54 to read, modify and write XML and HTML files. There is DTDs support
55 this includes parsing and validation even with complex DTDs, either
56 at parse time or later once the document has been modified.
57
58 %prep
59 %setup -q
60
61 %build
62 %configure
63 make %{_smp_mflags}
64 gzip -9 ChangeLog
65
66 %install
67 rm -fr %{buildroot}
68
69 %makeinstall
70 (cd doc/examples ; make clean ; rm -rf .deps Makefile)
71 gzip -9 doc/libxml2-api.xml
72 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
73
74 %clean
75 rm -fr %{buildroot}
76
77 %post
78 /sbin/ldconfig
79
80 %postun
81 /sbin/ldconfig
82
83 %files
84 %defattr(-, root, root)
85
86 %doc AUTHORS ChangeLog.gz NEWS README Copyright TODO
87 %doc %{_mandir}/man1/xmllint.1*
88 %doc %{_mandir}/man1/xmlcatalog.1*
89 %doc %{_mandir}/man3/libxml.3*
90
91 %{_libdir}/lib*.so.*
92 %{_bindir}/xmllint
93 %{_bindir}/xmlcatalog
94
95 %files devel
96 %defattr(-, root, root)
97
98 %doc %{_mandir}/man1/xml2-config.1*
99 %doc AUTHORS ChangeLog.gz NEWS README Copyright
100 %doc doc/*.html doc/html doc/*.gif doc/*.png
101 %doc doc/tutorial doc/libxml2-api.xml.gz
102 %doc doc/examples
103 %doc %dir %{_datadir}/gtk-doc/html/libxml2
104 %doc %{_datadir}/gtk-doc/html/libxml2/*.devhelp
105 %doc %{_datadir}/gtk-doc/html/libxml2/*.html
106 %doc %{_datadir}/gtk-doc/html/libxml2/*.png
107 %doc %{_datadir}/gtk-doc/html/libxml2/*.css
108
109 %{_libdir}/lib*.so
110 %{_libdir}/*a
111 %{_libdir}/*.sh
112 %{_includedir}/*
113 %{_bindir}/xml2-config
114 %{_datadir}/aclocal/libxml.m4
115 %{_libdir}/pkgconfig/libxml-2.0.pc
116 %files python
117 %defattr(-, root, root)
118
119 %doc AUTHORS ChangeLog.gz NEWS README Copyright
120 %{_libdir}/python*/site-packages/libxml2.py*
121 %{_libdir}/python*/site-packages/drv_libxml2.py*
122 %{_libdir}/python*/site-packages/libxml2mod*
123 %doc python/TODO
124 %doc python/libxml2class.txt
125 %doc python/tests/*.py
126 %doc doc/*.py
127 %doc doc/python.html
128
129 %changelog
130 * Tue Oct 6 2009 Daniel Veillard <veillard@redhat.com>
131 - upstream release 2.7.6 see http://xmlsoft.org/news.html
132