[TESTS] Add a test for spec2def
[reactos.git] / modules / rostests / tests / spec2def / test.spec
1 ; Comments be here()
2
3 # 2 stdcall CommentedOutFunction(ptr long ptr ptr) # comment 2
4 6 fastcall FastcallFunction(ptr ptr ptr long)
5 @ stdcall StdcallFunction(long)
6 8 fastcall -ret64 Ret64Function(double)
7
8 7 fastcall -arch=i386 Fastcalli386(long)
9 10 stdcall -arch=i386,x86_64 Stdcalli386x64()
10
11 @ stdcall -version=0x351-0x502 StdcallVersionRange(long long wstr wstr)
12 @ stdcall -stub -version=0x600+ StdcallStubVersion600(ptr)
13
14 @ stdcall StdcallForwarderToSameDll() StdcallTargetInSameDll
15 @ stdcall -version=0x600+ StdcallForwarder(ptr ptr ptr) ntdll.RtlStdcallForwarder
16
17 @ stub StubFunction
18 @ stdcall -stub StdcallSuccessStub(ptr)
19