788666a6948b6b6f5eeb543cd169ba6038ace8e5
[reactos.git] / reactos / dll / win32 / iphlpapi / iphlpapi.spec
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stub AllocateAndGetTcpExTable2FromStack
8 @ stub AllocateAndGetTcpExTableFromStack
9 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
10 @ stub AllocateAndGetUdpExTable2FromStack
11 @ stub AllocateAndGetUdpExTableFromStack
12 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
13 @ stub CancelIPChangeNotify
14 @ stub CancelSecurityHealthChangeNotify
15 @ stdcall CreateIpForwardEntry( ptr )
16 @ stdcall CreateIpNetEntry( ptr )
17 @ stdcall CreateProxyArpEntry( long long long )
18 @ stdcall DeleteIPAddress( long )
19 @ stdcall DeleteIpForwardEntry( ptr )
20 @ stdcall DeleteIpNetEntry( ptr )
21 @ stdcall DeleteProxyArpEntry( long long long )
22 @ stub DisableMediaSense
23 @ stdcall EnableRouter( ptr ptr )
24 @ stdcall FlushIpNetTable( long )
25 @ stub FlushIpNetTableFromStack
26 @ stdcall GetAdapterIndex( wstr ptr )
27 @ stub GetAdapterOrderMap
28 @ stdcall GetAdaptersAddresses( long long ptr ptr ptr )
29 @ stdcall GetAdaptersInfo( ptr ptr )
30 @ stdcall GetBestInterface( long ptr )
31 @ stub GetBestInterfaceEx
32 @ stub GetBestInterfaceFromStack
33 @ stdcall GetBestRoute( long long long )
34 @ stub GetBestRouteFromStack
35 @ stub GetExtendedTcpTable
36 @ stub GetExtendedUdpTable
37 @ stdcall GetFriendlyIfIndex( long )
38 @ stdcall GetIcmpStatistics( ptr )
39 @ stub GetIcmpStatisticsEx
40 @ stub GetIcmpStatsFromStack
41 @ stub GetIcmpStatsFromStackEx
42 @ stdcall GetIfEntry( ptr )
43 @ stdcall GetIfEntry2( ptr )
44 @ stub GetIfEntryFromStack
45 @ stdcall GetIfTable( ptr ptr long )
46 @ stdcall GetIfTable2(ptr)
47 @ stub GetIfTableFromStack
48 @ stub GetIgmpList
49 @ stdcall GetInterfaceInfo( ptr ptr )
50 @ stdcall GetIpAddrTable( ptr ptr long )
51 @ stub GetIpAddrTableFromStack
52 @ stub GetIpErrorString
53 @ stdcall GetIpForwardTable( ptr ptr long )
54 @ stub GetIpForwardTableFromStack
55 @ stdcall GetIpNetTable( ptr ptr long )
56 @ stub GetIpNetTableFromStack
57 @ stdcall GetIpStatistics( ptr )
58 @ stub GetIpStatisticsEx
59 @ stub GetIpStatsFromStack
60 @ stub GetIpStatsFromStackEx
61 @ stdcall GetNetworkParams( ptr ptr )
62 @ stdcall GetNumberOfInterfaces( ptr )
63 @ stub GetOwnerModuleFromTcp6Entry
64 @ stub GetOwnerModuleFromTcpEntry
65 @ stub GetOwnerModuleFromUdp6Entry
66 @ stub GetOwnerModuleFromUdpEntry
67 @ stdcall GetPerAdapterInfo( long ptr ptr )
68 @ stdcall GetRTTAndHopCount( long ptr long ptr )
69 @ stub GetTcpExTable2FromStack
70 @ stdcall GetTcpStatistics( ptr )
71 @ stub GetTcpStatisticsEx
72 @ stub GetTcpStatsFromStack
73 @ stub GetTcpStatsFromStackEx
74 @ stdcall GetTcpTable( ptr ptr long )
75 @ stub GetTcpTableFromStack
76 @ stub GetUdpExTable2FromStack
77 @ stdcall GetUdpStatistics( ptr )
78 @ stub GetUdpStatisticsEx
79 @ stub GetUdpStatsFromStack
80 @ stub GetUdpStatsFromStackEx
81 @ stdcall GetUdpTable( ptr ptr long )
82 @ stub GetUdpTableFromStack
83 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
84 @ stub Icmp6CreateFile
85 @ stub Icmp6ParseReplies
86 @ stub Icmp6SendEcho2
87 @ stub IcmpCloseHandle
88 @ stub IcmpCreateFile
89 @ stub IcmpParseReplies
90 @ stub IcmpSendEcho
91 @ stub IcmpSendEcho2
92 @ stub InternalCreateIpForwardEntry
93 @ stub InternalCreateIpNetEntry
94 @ stub InternalDeleteIpForwardEntry
95 @ stub InternalDeleteIpNetEntry
96 @ stub InternalGetIfTable
97 @ stub InternalGetIpAddrTable
98 @ stub InternalGetIpForwardTable
99 @ stub InternalGetIpNetTable
100 @ stub InternalGetTcpTable
101 @ stub InternalGetUdpTable
102 @ stub InternalSetIfEntry
103 @ stub InternalSetIpForwardEntry
104 @ stub InternalSetIpNetEntry
105 @ stub InternalSetIpStats
106 @ stub InternalSetTcpEntry
107 @ stdcall IpReleaseAddress( ptr )
108 @ stdcall IpRenewAddress( ptr )
109 @ stub IsLocalAddress
110 @ stub NTPTimeToNTFileTime
111 @ stub NTTimeToNTPTime
112 @ stub NhGetGuidFromInterfaceName
113 @ stdcall NhGetInterfaceNameFromDeviceGuid(long long long long long)
114 @ stub NhGetInterfaceNameFromGuid
115 @ stub NhpAllocateAndGetInterfaceInfoFromStack
116 @ stub NhpGetInterfaceIndexFromStack
117 @ stdcall NotifyAddrChange( ptr ptr )
118 @ stdcall NotifyRouteChange( ptr ptr )
119 @ stub NotifyRouteChangeEx
120 @ stub NotifySecurityHealthChange
121 @ stub RestoreMediaSense
122 @ stub SendARP
123 @ stub SetAdapterIpAddress
124 @ stub SetBlockRoutes
125 @ stdcall SetIfEntry( ptr )
126 @ stub SetIfEntryToStack
127 @ stdcall SetIpForwardEntry( ptr )
128 @ stdcall SetIpForwardEntryToStack( ptr )
129 @ stub SetIpMultihopRouteEntryToStack
130 @ stdcall SetIpNetEntry( ptr )
131 @ stub SetIpNetEntryToStack
132 @ stub SetIpRouteEntryToStack
133 @ stdcall SetIpStatistics( ptr )
134 @ stub SetIpStatsToStack
135 @ stdcall SetIpTTL( long )
136 @ stub SetProxyArpEntryToStack
137 @ stub SetRouteWithRef
138 @ stdcall SetTcpEntry( ptr )
139 @ stub SetTcpEntryToStack
140 @ stdcall UnenableRouter( ptr ptr )
141 @ stub _PfAddFiltersToInterface@24
142 @ stub _PfAddGlobalFilterToInterface@8
143 @ stub _PfBindInterfaceToIPAddress@12
144 @ stub _PfBindInterfaceToIndex@16
145 @ stub _PfCreateInterface@24
146 @ stub _PfDeleteInterface@4
147 @ stub _PfDeleteLog@0
148 @ stub _PfGetInterfaceStatistics@16
149 @ stub _PfMakeLog@4
150 @ stub _PfRebindFilters@8
151 @ stub _PfRemoveFilterHandles@12
152 @ stub _PfRemoveFiltersFromInterface@20
153 @ stub _PfRemoveGlobalFilterFromInterface@8
154 @ stub _PfSetLogBuffer@28
155 @ stub _PfTestPacket@20
156 @ stub _PfUnBindInterface@4
157 @ stub do_echo_rep
158 @ stub do_echo_req
159 @ stub register_icmp