Rbuild changes for include structure change.
[reactos.git] / reactos / dll / win32 / msvideo / msvideo.spec
1 2 pascal VideoForWindowsVersion() VideoForWindowsVersion
2 20 stub VIDEOGETNUMDEVS
3 21 stub VIDEOGETERRORTEXT
4 22 pascal VideoCapDriverDescAndVer(word ptr word ptr word) VideoCapDriverDescAndVer16
5 28 stub VIDEOOPEN
6 29 stub VIDEOCLOSE
7 30 stub VIDEODIALOG
8 31 stub VIDEOFRAME
9 32 stub VIDEOCONFIGURE
10 33 stub VIDEOCONFIGURESTORAGE
11 34 stub VIDEOGETCHANNELCAPS
12 35 stub VIDEOUPDATE
13 40 stub VIDEOSTREAMADDBUFFER
14 41 stub VIDEOSTREAMFINI
15 42 stub VIDEOSTREAMGETERROR
16 43 stub VIDEOSTREAMGETPOSITION
17 44 stub VIDEOSTREAMINIT
18 46 stub VIDEOSTREAMPREPAREHEADER
19 47 stub VIDEOSTREAMRESET
20 49 stub VIDEOSTREAMSTART
21 50 stub VIDEOSTREAMSTOP
22 51 stub VIDEOSTREAMUNPREPAREHEADER
23 52 stub VIDEOSTREAMALLOCHDRANDBUFFER
24 53 stub VIDEOSTREAMFREEHDRANDBUFFER
25 60 stub VIDEOMESSAGE
26 102 pascal -ret16 DrawDibOpen() DrawDibOpen16
27 103 pascal -ret16 DrawDibClose(word) DrawDibClose16
28 104 pascal -ret16 DrawDibBegin(word word s_word s_word ptr s_word s_word word) DrawDibBegin16
29 105 pascal -ret16 DrawDibEnd(word) DrawDibEnd16
30 106 pascal -ret16 DrawDibDraw(word word s_word s_word s_word s_word ptr ptr s_word s_word s_word s_word word) DrawDibDraw16
31 108 pascal -ret16 DrawDibGetPalette(word) DrawDibGetPalette16
32 110 pascal -ret16 DrawDibSetPalette(word word) DrawDibSetPalette16
33 111 stub DRAWDIBCHANGEPALETTE
34 112 pascal -ret16 DrawDibRealize(word word word) DrawDibRealize16
35 113 stub DRAWDIBTIME
36 114 stub DRAWDIBPROFILEDISPLAY
37 115 stub STRETCHDIB
38 118 pascal -ret16 DrawDibStart(word long) DrawDibStart16
39 119 pascal -ret16 DrawDibStop(word) DrawDibStop16
40 120 stub DRAWDIBGETBUFFER
41 200 pascal -ret16 ICInfo(long long segptr) ICInfo16
42 201 stub ICINSTALL
43 202 stub ICREMOVE
44 203 pascal -ret16 ICOpen(long long word) ICOpen16
45 204 pascal ICClose(word) ICClose16
46 205 pascal ICSendMessage(word word long long) ICSendMessage16
47 206 pascal -ret16 ICOpenFunction(long long word segptr) ICOpenFunction16
48 207 varargs _ICMessage(word word word) ICMessage16
49 212 pascal ICGetInfo(word segptr long) ICGetInfo16
50 213 pascal -ret16 ICLocate(long long ptr ptr word) ICLocate16
51 224 cdecl _ICCompress(word long segptr segptr segptr segptr segptr segptr long long long segptr segptr) ICCompress16
52 230 cdecl _ICDecompress(word long segptr segptr segptr segptr) ICDecompress16
53 232 cdecl _ICDrawBegin(word long word word word s_word s_word s_word s_word segptr s_word s_word s_word s_word long long) ICDrawBegin16
54 234 cdecl _ICDraw(word long segptr segptr long long) ICDraw16
55 239 pascal -ret16 ICGetDisplayFormat(word ptr ptr s_word s_word s_word) ICGetDisplayFormat16
56 240 stub ICIMAGECOMPRESS
57 241 stub ICIMAGEDECOMPRESS
58 242 stub ICCOMPRESSORCHOOSE
59 243 stub ICCOMPRESSORFREE
60 244 stub ICSEQCOMPRESSFRAMESTART
61 245 stub ICSEQCOMPRESSFRAMEEND
62 246 stub ICSEQCOMPRESSFRAME
63 250 stub _MCIWNDCREATE
64 251 stub _MCIWNDREGISTERCLASS
65 252 stub GETOPENFILENAMEPREVIEW
66 253 stub GETSAVEFILENAMEPREVIEW
67
68 300 pascal DllEntryPoint(long word word word long word) VIDEO_LibMain