reshuffling of dlls
[reactos.git] / reactos / dll / win32 / netapi32 / netapi32.spec
1 @ stub DsAddressToSiteNames
2 @ stub DsAddressToSiteNamesEx
3 @ stub DsDeregisterDnsHostRecords
4 @ stub DsEnumerateDomainTrusts
5 @ stub DsGetDcClose
6 @ stub DsGetDcName
7 @ stub DsGetDcNext
8 @ stub DsGetDcOpen
9 @ stub DsGetDcSiteCoverage
10 @ stub DsGetForestTrustInformationW
11 @ stub DsGetSiteName
12 @ stub DsMergeForestTrustInformationW
13 @ stdcall DsRoleFreeMemory(ptr)
14 @ stdcall DsRoleGetPrimaryDomainInformation(wstr long ptr)
15 @ stub DsValidateSubnetName
16 @ stub I_BrowserDebugCall
17 @ stub I_BrowserDebugTrace
18 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr)
19 @ stub I_BrowserQueryOtherDomains
20 @ stub I_BrowserQueryStatistics
21 @ stub I_BrowserResetNetlogonState
22 @ stub I_BrowserResetStatistics
23 @ stub I_BrowserServerEnum
24 @ stdcall I_BrowserSetNetlogonState(wstr wstr wstr long)
25 @ stub I_NetAccountDeltas
26 @ stub I_NetAccountSync
27 @ stub I_NetDatabaseDeltas
28 @ stub I_NetDatabaseRedo
29 @ stub I_NetDatabaseSync2
30 @ stub I_NetDatabaseSync
31 @ stub I_NetDfsCreateExitPoint
32 @ stub I_NetDfsCreateLocalPartition
33 @ stub I_NetDfsDeleteExitPoint
34 @ stub I_NetDfsDeleteLocalPartition
35 @ stub I_NetDfsFixLocalVolume
36 @ stub I_NetDfsGetVersion
37 @ stub I_NetDfsIsThisADomainName
38 @ stub I_NetDfsModifyPrefix
39 @ stub I_NetDfsSetLocalVolumeState
40 @ stub I_NetDfsSetServerInfo
41 @ stub I_NetGetDCList
42 @ stub I_NetListCanonicalize
43 @ stub I_NetListTraverse
44 @ stub I_NetLogonControl2
45 @ stub I_NetLogonControl
46 @ stub I_NetLogonSamLogoff
47 @ stub I_NetLogonSamLogon
48 @ stub I_NetLogonUasLogoff
49 @ stub I_NetLogonUasLogon
50 @ stub I_NetNameCanonicalize
51 @ stdcall I_NetNameCompare(ptr wstr wstr ptr ptr)
52 @ stdcall I_NetNameValidate(ptr wstr ptr ptr)
53 @ stub I_NetPathCanonicalize
54 @ stub I_NetPathCompare
55 @ stub I_NetPathType
56 @ stub I_NetServerAuthenticate2
57 @ stub I_NetServerAuthenticate
58 @ stub I_NetServerPasswordSet
59 @ stub I_NetServerReqChallenge
60 @ stub I_NetServerSetServiceBits
61 @ stub I_NetServerSetServiceBitsEx
62 @ stub NetAlertRaise
63 @ stub NetAlertRaiseEx
64 @ stdcall NetApiBufferAllocate(long ptr)
65 @ stdcall NetApiBufferFree(ptr)
66 @ stdcall NetApiBufferReallocate(ptr long ptr)
67 @ stdcall NetApiBufferSize(ptr ptr)
68 @ stub NetAuditClear
69 @ stub NetAuditRead
70 @ stub NetAuditWrite
71 @ stub NetBrowserStatisticsGet
72 @ stub NetConfigGet
73 @ stub NetConfigGetAll
74 @ stub NetConfigSet
75 @ stub NetConnectionEnum
76 @ stub NetDfsAdd
77 @ stub NetDfsEnum
78 @ stub NetDfsGetInfo
79 @ stub NetDfsManagerGetConfigInfo
80 @ stub NetDfsMove
81 @ stub NetDfsRemove
82 @ stub NetDfsRename
83 @ stub NetDfsSetInfo
84 @ stub NetEnumerateTrustedDomains
85 @ stub NetErrorLogClear
86 @ stub NetErrorLogRead
87 @ stub NetErrorLogWrite
88 @ stub NetFileClose
89 @ stub NetFileEnum
90 @ stub NetFileGetInfo
91 @ stub NetGetAnyDCName
92 @ stdcall NetGetDCName(wstr wstr ptr)
93 @ stub NetGetDisplayInformationIndex
94 @ stdcall NetGetJoinInformation(wstr ptr ptr)
95 @ stub NetGroupAdd
96 @ stub NetGroupAddUser
97 @ stub NetGroupDel
98 @ stub NetGroupDelUser
99 @ stub NetGroupEnum
100 @ stub NetGroupGetInfo
101 @ stub NetGroupGetUsers
102 @ stub NetGroupSetInfo
103 @ stub NetGroupSetUsers
104 @ stdcall NetLocalGroupAdd(wstr long ptr ptr)
105 @ stub NetLocalGroupAddMember
106 @ stub NetLocalGroupAddMembers
107 @ stub NetLocalGroupDel
108 @ stub NetLocalGroupDelMember
109 @ stub NetLocalGroupDelMembers
110 @ stub NetLocalGroupEnum
111 @ stub NetLocalGroupGetInfo
112 @ stub NetLocalGroupGetMembers
113 @ stub NetLocalGroupSetInfo
114 @ stdcall NetLocalGroupSetMembers(wstr wstr long ptr ptr)
115 @ stub NetMessageBufferSend
116 @ stub NetMessageNameAdd
117 @ stub NetMessageNameDel
118 @ stub NetMessageNameEnum
119 @ stub NetMessageNameGetInfo
120 @ stdcall NetQueryDisplayInformation(wstr long long long long ptr ptr)
121 @ stub NetRemoteComputerSupports
122 @ stub NetRemoteTOD
123 @ stub NetReplExportDirAdd
124 @ stub NetReplExportDirDel
125 @ stub NetReplExportDirEnum
126 @ stub NetReplExportDirGetInfo
127 @ stub NetReplExportDirLock
128 @ stub NetReplExportDirSetInfo
129 @ stub NetReplExportDirUnlock
130 @ stub NetReplGetInfo
131 @ stub NetReplImportDirAdd
132 @ stub NetReplImportDirDel
133 @ stub NetReplImportDirEnum
134 @ stub NetReplImportDirGetInfo
135 @ stub NetReplImportDirLock
136 @ stub NetReplImportDirUnlock
137 @ stub NetReplSetInfo
138 @ stub NetRplAdapterAdd
139 @ stub NetRplAdapterDel
140 @ stub NetRplAdapterEnum
141 @ stub NetRplBootAdd
142 @ stub NetRplBootDel
143 @ stub NetRplBootEnum
144 @ stub NetRplClose
145 @ stub NetRplConfigAdd
146 @ stub NetRplConfigDel
147 @ stub NetRplConfigEnum
148 @ stub NetRplGetInfo
149 @ stub NetRplOpen
150 @ stub NetRplProfileAdd
151 @ stub NetRplProfileClone
152 @ stub NetRplProfileDel
153 @ stub NetRplProfileEnum
154 @ stub NetRplProfileGetInfo
155 @ stub NetRplProfileSetInfo
156 @ stub NetRplSetInfo
157 @ stub NetRplSetSecurity
158 @ stub NetRplVendorAdd
159 @ stub NetRplVendorDel
160 @ stub NetRplVendorEnum
161 @ stub NetRplWkstaAdd
162 @ stub NetRplWkstaClone
163 @ stub NetRplWkstaDel
164 @ stub NetRplWkstaEnum
165 @ stub NetRplWkstaGetInfo
166 @ stub NetRplWkstaSetInfo
167 @ stub NetScheduleJobAdd
168 @ stub NetScheduleJobDel
169 @ stub NetScheduleJobEnum
170 @ stub NetScheduleJobGetInfo
171 @ stub NetServerComputerNameAdd
172 @ stub NetServerComputerNameDel
173 @ stub NetServerDiskEnum
174 @ stdcall NetServerEnum(wstr long ptr long ptr ptr long wstr ptr)
175 @ stub NetServerEnumEx
176 @ stdcall NetServerGetInfo(wstr long ptr)
177 @ stub NetServerSetInfo
178 @ stub NetServerTransportAdd
179 @ stub NetServerTransportAddEx
180 @ stub NetServerTransportDel
181 @ stub NetServerTransportEnum
182 @ stub NetServiceControl
183 @ stub NetServiceEnum
184 @ stub NetServiceGetInfo
185 @ stub NetServiceInstall
186 @ stub NetSessionDel
187 @ stub NetSessionEnum
188 @ stub NetSessionGetInfo
189 @ stub NetShareAdd
190 @ stub NetShareCheck
191 @ stub NetShareDel
192 @ stub NetShareDelSticky
193 @ stdcall NetShareEnum(wstr long ptr long ptr ptr ptr)
194 @ stub NetShareEnumSticky
195 @ stub NetShareGetInfo
196 @ stub NetShareSetInfo
197 @ stdcall NetStatisticsGet(wstr wstr long long ptr)
198 @ stub NetUseAdd
199 @ stub NetUseDel
200 @ stub NetUseEnum
201 @ stub NetUseGetInfo
202 @ stdcall NetUserAdd(wstr long ptr ptr)
203 @ stub NetUserChangePassword
204 @ stdcall NetUserDel(wstr wstr)
205 @ stdcall NetUserEnum(wstr long long ptr long ptr ptr ptr)
206 @ stub NetUserGetGroups
207 @ stdcall NetUserGetInfo(wstr wstr long ptr)
208 @ stub NetUserGetLocalGroups
209 @ stdcall NetUserModalsGet(wstr long ptr)
210 @ stub NetUserModalsSet
211 @ stub NetUserSetGroups
212 @ stub NetUserSetInfo
213 @ stdcall NetWkstaGetInfo(wstr long ptr)
214 @ stub NetWkstaSetInfo
215 @ stub NetWkstaTransportAdd
216 @ stub NetWkstaTransportDel
217 @ stdcall NetWkstaTransportEnum (wstr long ptr long ptr ptr ptr)
218 @ stub NetWkstaUserEnum
219 @ stdcall NetWkstaUserGetInfo(wstr long ptr)
220 @ stub NetWkstaUserSetInfo
221 @ stdcall NetapipBufferAllocate(long ptr) NetApiBufferAllocate
222 @ stdcall Netbios(ptr)
223 @ stub NetpAccessCheck
224 @ stub NetpAccessCheckAndAudit
225 @ stub NetpAllocConfigName
226 @ stub NetpAllocStrFromStr
227 @ stub NetpAllocStrFromWStr
228 @ stub NetpAllocTStrFromString
229 @ stub NetpAllocWStrFromStr
230 @ stub NetpAllocWStrFromWStr
231 @ stub NetpApiStatusToNtStatus
232 @ stub NetpAssertFailed
233 @ stub NetpCloseConfigData
234 @ stub NetpCopyStringToBuffer
235 @ stub NetpCreateSecurityObject
236 @ stub NetpDbgDisplayServerInfo
237 @ stub NetpDbgPrint
238 @ stdcall NetpDeleteSecurityObject(long) ntdll.RtlDeleteSecurityObject
239 @ stdcall NetpGetComputerName(ptr)
240 @ stub NetpGetConfigBool
241 @ stub NetpGetConfigDword
242 @ stub NetpGetConfigTStrArray
243 @ stub NetpGetConfigValue
244 @ stub NetpGetDomainName
245 @ stub NetpGetFileSecurity
246 @ stub NetpGetPrivilege
247 @ stub NetpHexDump
248 @ stdcall NetpInitOemString(ptr str) ntdll.RtlInitAnsiString
249 @ stub NetpIsRemote
250 @ stub NetpIsUncComputerNameValid
251 @ stub NetpLocalTimeZoneOffset
252 @ stub NetpLogonPutUnicodeString
253 @ stub NetpNetBiosAddName
254 @ stub NetpNetBiosCall
255 @ stub NetpNetBiosDelName
256 @ stub NetpNetBiosGetAdapterNumbers
257 @ stub NetpNetBiosHangup
258 @ stub NetpNetBiosReceive
259 @ stub NetpNetBiosReset
260 @ stub NetpNetBiosSend
261 @ stdcall NetpNetBiosStatusToApiStatus(long)
262 @ stub NetpNtStatusToApiStatus
263 @ stub NetpOpenConfigData
264 @ stub NetpPackString
265 @ stub NetpReleasePrivilege
266 @ stub NetpSetConfigBool
267 @ stub NetpSetConfigDword
268 @ stub NetpSetConfigTStrArray
269 @ stub NetpSetFileSecurity
270 @ stub NetpSmbCheck
271 @ stub NetpStringToNetBiosName
272 @ stub NetpTStrArrayEntryCount
273 @ stub NetpwNameCanonicalize
274 @ stub NetpwNameCompare
275 @ stub NetpwNameValidate
276 @ stub NetpwPathCanonicalize
277 @ stub NetpwPathCompare
278 @ stub NetpwPathType
279 @ stub NlBindingAddServerToCache
280 @ stub NlBindingRemoveServerFromCache
281 @ stub NlBindingSetAuthInfo
282 @ stub RxNetAccessAdd
283 @ stub RxNetAccessDel
284 @ stub RxNetAccessEnum
285 @ stub RxNetAccessGetInfo
286 @ stub RxNetAccessGetUserPerms
287 @ stub RxNetAccessSetInfo
288 @ stub RxNetServerEnum
289 @ stub RxNetUserPasswordSet
290 @ stub RxRemoteApi