b475d5392c640bf016184ebda6168548ecb44aa8
[reactos.git] / reactos / dll / win32 / pdh / pdh.spec
1 1 stub PdhPlaGetLogFileNameA
2 @ stub PdhAdd009CounterA
3 @ stub PdhAdd009CounterW
4 @ stdcall PdhAddCounterA(ptr str long ptr)
5 @ stdcall PdhAddCounterW(ptr wstr long ptr)
6 @ stdcall PdhAddEnglishCounterA(ptr str long ptr)
7 @ stdcall PdhAddEnglishCounterW(ptr wstr long ptr)
8 @ stub PdhBindInputDataSourceA
9 @ stub PdhBindInputDataSourceW
10 @ stub PdhBrowseCountersA
11 @ stub PdhBrowseCountersHA
12 @ stub PdhBrowseCountersHW
13 @ stub PdhBrowseCountersW
14 @ stdcall PdhCalculateCounterFromRawValue(ptr long ptr ptr ptr)
15 @ stub PdhCloseLog
16 @ stdcall PdhCloseQuery(ptr)
17 @ stdcall PdhCollectQueryData(ptr)
18 @ stdcall PdhCollectQueryDataWithTime(ptr ptr)
19 @ stdcall PdhCollectQueryDataEx(ptr long ptr)
20 @ stub PdhComputeCounterStatistics
21 @ stub PdhConnectMachineA
22 @ stub PdhConnectMachineW
23 @ stub PdhCreateSQLTablesA
24 @ stub PdhCreateSQLTablesW
25 @ stub PdhEnumLogSetNamesA
26 @ stub PdhEnumLogSetNamesW
27 @ stub PdhEnumMachinesA
28 @ stub PdhEnumMachinesHA
29 @ stub PdhEnumMachinesHW
30 @ stub PdhEnumMachinesW
31 @ stdcall PdhEnumObjectItemsA(str str str ptr ptr ptr ptr long long)
32 @ stub PdhEnumObjectItemsHA
33 @ stub PdhEnumObjectItemsHW
34 @ stdcall PdhEnumObjectItemsW(wstr wstr wstr ptr ptr ptr ptr long long)
35 @ stub PdhEnumObjectsA
36 @ stub PdhEnumObjectsHA
37 @ stub PdhEnumObjectsHW
38 @ stub PdhEnumObjectsW
39 @ stub PdhExpandCounterPathA
40 @ stub PdhExpandCounterPathW
41 @ stdcall PdhExpandWildCardPathA(str str ptr ptr long)
42 @ stub PdhExpandWildCardPathHA
43 @ stub PdhExpandWildCardPathHW
44 @ stdcall PdhExpandWildCardPathW(wstr wstr ptr ptr long)
45 @ stub PdhFormatFromRawValue
46 @ stdcall PdhGetCounterInfoA(ptr long ptr ptr)
47 @ stdcall PdhGetCounterInfoW(ptr long ptr ptr)
48 @ stdcall PdhGetCounterTimeBase(ptr ptr)
49 @ stub PdhGetDataSourceTimeRangeA
50 @ stub PdhGetDataSourceTimeRangeH
51 @ stub PdhGetDataSourceTimeRangeW
52 @ stub PdhGetDefaultPerfCounterA
53 @ stub PdhGetDefaultPerfCounterHA
54 @ stub PdhGetDefaultPerfCounterHW
55 @ stub PdhGetDefaultPerfCounterW
56 @ stub PdhGetDefaultPerfObjectA
57 @ stub PdhGetDefaultPerfObjectHA
58 @ stub PdhGetDefaultPerfObjectHW
59 @ stub PdhGetDefaultPerfObjectW
60 @ stdcall PdhGetDllVersion(ptr)
61 @ stub PdhGetFormattedCounterArrayA
62 @ stub PdhGetFormattedCounterArrayW
63 @ stdcall PdhGetFormattedCounterValue(ptr long ptr ptr)
64 @ stub PdhGetLogFileSize
65 @ stub PdhGetLogFileTypeA
66 @ stub PdhGetLogFileTypeW
67 @ stub PdhGetLogSetGUID
68 @ stub PdhGetRawCounterArrayA
69 @ stub PdhGetRawCounterArrayW
70 @ stdcall PdhGetRawCounterValue(ptr ptr ptr)
71 @ stub PdhIsRealTimeQuery
72 @ stub PdhListLogFileHeaderA
73 @ stub PdhListLogFileHeaderW
74 @ stub PdhLogServiceCommandA
75 @ stub PdhLogServiceCommandW
76 @ stub PdhLogServiceControlA
77 @ stub PdhLogServiceControlW
78 @ stdcall PdhLookupPerfIndexByNameA(str str ptr)
79 @ stdcall PdhLookupPerfIndexByNameW(wstr wstr ptr)
80 @ stdcall PdhLookupPerfNameByIndexA(str long ptr ptr)
81 @ stdcall PdhLookupPerfNameByIndexW(wstr long ptr ptr)
82 @ stdcall PdhMakeCounterPathA(ptr ptr ptr long)
83 @ stdcall PdhMakeCounterPathW(ptr ptr ptr long)
84 @ stub PdhOpenLogA
85 @ stub PdhOpenLogW
86 @ stdcall PdhOpenQuery(wstr long ptr) PdhOpenQueryW
87 @ stdcall PdhOpenQueryA(str long ptr)
88 @ stub PdhOpenQueryH
89 @ stdcall PdhOpenQueryW(wstr long ptr)
90 @ stub PdhParseCounterPathA
91 @ stub PdhParseCounterPathW
92 @ stub PdhParseInstanceNameA
93 @ stub PdhParseInstanceNameW
94 @ stub PdhPlaAddItemA
95 @ stub PdhPlaAddItemW
96 @ stub PdhPlaCreateA
97 @ stub PdhPlaCreateW
98 @ stub PdhPlaDeleteA
99 @ stub PdhPlaDeleteW
100 @ stub PdhPlaEnumCollectionsA
101 @ stub PdhPlaEnumCollectionsW
102 @ stub PdhPlaGetInfoA
103 @ stub PdhPlaGetInfoW
104 @ stub PdhPlaGetLogFileNameW
105 @ stub PdhPlaGetScheduleA
106 @ stub PdhPlaGetScheduleW
107 @ stub PdhPlaRemoveAllItemsA
108 @ stub PdhPlaRemoveAllItemsW
109 @ stub PdhPlaScheduleA
110 @ stub PdhPlaScheduleW
111 @ stub PdhPlaSetInfoA
112 @ stub PdhPlaSetInfoW
113 @ stub PdhPlaSetItemListA
114 @ stub PdhPlaSetItemListW
115 @ stub PdhPlaSetRunAsA
116 @ stub PdhPlaSetRunAsW
117 @ stub PdhPlaStartA
118 @ stub PdhPlaStartW
119 @ stub PdhPlaStopA
120 @ stub PdhPlaStopW
121 @ stub PdhPlaValidateInfoA
122 @ stub PdhPlaValidateInfoW
123 @ stub PdhReadRawLogRecord
124 @ stub PdhRelogA
125 @ stub PdhRelogW
126 @ stdcall PdhRemoveCounter(ptr)
127 @ stub PdhSelectDataSourceA
128 @ stub PdhSelectDataSourceW
129 @ stdcall PdhSetCounterScaleFactor(ptr long)
130 @ stdcall PdhSetDefaultRealTimeDataSource(long)
131 @ stub PdhSetLogSetRunID
132 @ stub PdhSetQueryTimeRange
133 @ stub PdhTranslate009CounterA
134 @ stub PdhTranslate009CounterW
135 @ stub PdhTranslateLocaleCounterA
136 @ stub PdhTranslateLocaleCounterW
137 @ stub PdhUpdateLogA
138 @ stub PdhUpdateLogFileCatalog
139 @ stub PdhUpdateLogW
140 @ stdcall PdhValidatePathA(str)
141 @ stdcall PdhValidatePathExA(ptr str)
142 @ stdcall PdhValidatePathExW(ptr wstr)
143 @ stdcall PdhValidatePathW(wstr)
144 @ stub PdhVbAddCounter
145 @ stub PdhVbCreateCounterPathList
146 @ stub PdhVbGetCounterPathElements
147 @ stub PdhVbGetCounterPathFromList
148 @ stub PdhVbGetDoubleCounterValue
149 @ stub PdhVbGetLogFileSize
150 @ stub PdhVbGetOneCounterPath
151 @ stub PdhVbIsGoodStatus
152 @ stub PdhVbOpenLog
153 @ stub PdhVbOpenQuery
154 @ stub PdhVbUpdateLog
155 @ stub PdhVerifySQLDBA
156 @ stub PdhVerifySQLDBW
157 @ stub PdhiPla2003SP1Installed
158 @ stub PdhiPlaFormatBlanksA
159 @ stub PdhiPlaFormatBlanksW
160 @ stub PdhiPlaGetVersion
161 @ stub PdhiPlaRunAs
162 @ stub PdhiPlaSetRunAs
163 @ stub PlaTimeInfoToMilliSeconds