* Reduce difference to the cmake branch.
[reactos.git] / reactos / dll / win32 / userenv / userenv.spec
1 132 stdcall CreateEnvironmentBlock(ptr ptr long)
2 133 stdcall DeleteProfileA(str str str)
3 134 stdcall DeleteProfileW(wstr wstr wstr)
4 176 stdcall DestroyEnvironmentBlock(ptr)
5 @ stub -private DllCanUnloadNow #stdcall DllCanUnloadNow()
6 @ stub -private DllGetClassObject #stdcall DllGetClassObject(ptr ptr ptr)
7 @ stub -private DllInstall #stdcall DllInstall(long wstr)
8 @ stub -private DllRegisterServer #stdcall DllRegisterServer()
9 @ stub -private DllUnregisterServer #stdcall DllUnregisterServer()
10 182 stdcall EnterCriticalPolicySection(long)
11 183 stdcall ExpandEnvironmentStringsForUserA(ptr str str long)
12 184 stdcall ExpandEnvironmentStringsForUserW(ptr wstr wstr long)
13 185 stub ForceSyncFgPolicy #stdcall ForceSyncFgPolicy(4)
14 186 stub FreeGPOListA #stdcall FreeGPOListA(ptr)
15 187 stub FreeGPOListW #stdcall FreeGPOListW(ptr)
16 188 stub GenerateRsopPolicy #stdcall GenerateRsopPolicy(48)
17 189 stdcall GetAllUsersProfileDirectoryA(str ptr)
18 190 stdcall GetAllUsersProfileDirectoryW(wstr ptr)
19 191 stub GetAppliedGPOListA #stdcall GetAppliedGPOListA(long str ptr ptr ptr)
20 192 stub GetAppliedGPOListW #stdcall GetAppliedGPOListW(long wstr ptr ptr ptr)
21 193 stdcall GetDefaultUserProfileDirectoryA(str ptr)
22 194 stdcall GetDefaultUserProfileDirectoryW(wstr ptr)
23 195 stub GetGPOListA #stdcall GetGPOListA(ptr str str str long ptr)
24 196 stub GetGPOListW #stdcall GetGPOListW(ptr wstr wstr wstr long ptr)
25 197 stub GetNextFgPolicyRefreshInfo #stdcall GetNextFgPolicyRefreshInfo(8)
26 198 stub GetPreviousFgPolicyRefreshInfo #stdcall GetPreviousFgPolicyRefreshInfo(8)
27 199 stub GetProfileType #stdcall GetProfileType(ptr)
28 202 stdcall GetProfilesDirectoryA(str ptr)
29 203 stdcall GetProfilesDirectoryW(wstr ptr)
30 204 stdcall GetUserProfileDirectoryA(ptr str ptr)
31 205 stdcall GetUserProfileDirectoryW(ptr wstr ptr)
32 206 stdcall LeaveCriticalPolicySection(ptr)
33 207 stdcall LoadUserProfileA(ptr ptr)
34 208 stdcall LoadUserProfileW(ptr ptr)
35 209 stub ProcessGroupPolicyCompleted #stdcall ProcessGroupPolicyCompleted(ptr ptr long)
36 210 stub ProcessGroupPolicyCompletedEx #stdcall ProcessGroupPolicyCompletedEx(ptr ptr long ptr)
37 211 stdcall RefreshPolicy(long)
38 212 stdcall RefreshPolicyEx(long long)
39 213 stdcall RegisterGPNotification(ptr long)
40 214 stub RsopAccessCheckByType #stdcall RsopAccessCheckByType(ptr ptr ptr long ptr long ptr ptr ptr ptr ptr)
41 215 stub RsopFileAccessCheck #stdcall RsopFileAccessCheck(wstr ptr long ptr ptr)
42 216 stub RsopLoggingEnabled #stdcall RsopLoggingEnabled()
43 217 stub RsopResetPolicySettingStatus #stdcall RsopResetPolicySettingStatus(long ptr ptr)
44 218 stub RsopSetPolicySettingStatus #stdcall RsopSetPolicySettingStatus(long ptr ptr long ptr)
45 219 stdcall UnloadUserProfile(ptr ptr)
46 220 stdcall UnregisterGPNotification(ptr)
47 221 stdcall WaitForMachinePolicyForegroundProcessing()
48 222 stdcall WaitForUserPolicyForegroundProcessing()
49 100 stdcall -noname InitializeProfiles()
50 101 stdcall -noname CreateGroupA(str long)
51 102 stdcall -noname CreateGroupW(wstr long)
52 103 stdcall -noname DeleteGroupA(str long)
53 104 stdcall -noname DeleteGroupW(wstr long)
54 105 stdcall -noname AddItemA(str long str str str long str long long)
55 106 stdcall -noname AddItemW(wstr long wstr wstr wstr long wstr long long)
56 107 stdcall -noname DeleteItemA(str long str long)
57 108 stdcall -noname DeleteItemW(wstr long wstr long)
58 109 stdcall -noname CreateUserProfileA(ptr str)
59 110 stdcall -noname CreateUserProfileW(ptr wstr)
60 111 stdcall -noname CopyProfileDirectoryA(str str long)
61 112 stdcall -noname CopyProfileDirectoryW(wstr wstr long)
62 113 stdcall -noname AddDesktopItemA(long str str str long str long long)
63 114 stdcall -noname AddDesktopItemW(long wstr wstr wstr long wstr long long)
64 115 stdcall -noname DeleteDesktopItemA(long str)
65 116 stdcall -noname DeleteDesktopItemW(long wstr)
66 117 stub -noname ApplyGroupPolicy #stdcall -noname ApplyGroupPolicy(20)
67 118 stub -noname ShutdownGPOProcessing #stdcall -noname ShutdownGPOProcessing(4)
68 119 stub -noname CreateLinkFileA #stdcall -noname CreateLinkFileA(40)
69 120 stub -noname CreateLinkFileW #stdcall -noname CreateLinkFileW(40)
70 121 stub -noname DeleteLinkFileA #stdcall -noname DeleteLinkFileA(16)
71 122 stub -noname DeleteLinkFileW #stdcall -noname DeleteLinkFileW(16)
72 123 stub -noname CopyProfileDirectoryExA #stdcall -noname CopyProfileDirectoryExA(20)
73 124 stub -noname CopyProfileDirectoryExW #stdcall -noname CopyProfileDirectoryExW(20)
74 125 stub -noname GetSystemTempDirectoryA #stdcall -noname GetSystemTempDirectoryA(8)
75 126 stub -noname GetSystemTempDirectoryW #stdcall -noname GetSystemTempDirectoryW(8)
76 127 stub -noname MigrateNT4ToNT5 #stdcall -noname MigrateNT4ToNT5()
77 128 stub -noname ResetUserSpecialFolderPaths #stdcall -noname ResetUserSpecialFolderPaths()
78 129 stub -noname ApplySystemPolicyA #stdcall -noname ApplySystemPolicyA(24)
79 130 stub -noname ApplySystemPolicyW #stdcall -noname ApplySystemPolicyW(24)
80 131 stub -noname DetermineProfilesLocation #stdcall -noname DetermineProfilesLocation(4)
81 135 stub -noname PingComputer #stdcall -noname PingComputer(8)
82 136 stub -noname CreateGroupExA #stdcall -noname CreateGroupExA(16)
83 137 stub -noname CreateGroupExW #stdcall -noname CreateGroupExW(16)
84 138 stub -noname CreateLinkFileExA #stdcall -noname CreateLinkFileExA(48)
85 139 stub -noname CreateLinkFileExW #stdcall -noname CreateLinkFileExW(48)
86 140 stub -noname InitializeUserProfile #stdcall -noname InitializeUserProfile()
87 #141 cdecl -noname RsopSidsFromToken@@YGJPAXPAPAU_TOKEN_GROUPS@@@Z
88 142 stub -noname GetUserSid #stdcall -noname GetUserSid(4)
89 143 stub -noname SecureUserProfiles #stdcall -noname SecureUserProfiles()
90 144 stub -noname EnterUserProfileLock #stdcall -noname EnterUserProfileLock(4)
91 145 stub -noname LeaveUserProfileLock #stdcall -noname LeaveUserProfileLock(4)
92 146 stub -noname CheckAccessForPolicyGeneration #stdcall -noname CheckAccessForPolicyGeneration(20)
93 147 stub -noname GetGroupPolicyNetworkName #stdcall -noname GetGroupPolicyNetworkName(8)
94 148 stub -noname GetUserAppDataPathA #stdcall -noname GetUserAppDataPathA(12)
95 149 stub -noname GetUserAppDataPathW #stdcall -noname GetUserAppDataPathW(12)
96 150 stub -noname SignalUserPolicyForegroundProcessingDone #stdcall -noname SignalUserPolicyForegroundProcessingDone()
97 151 stub -noname SignalMachinePolicyForegroundProcessingDone #stdcall -noname SignalMachinePolicyForegroundProcessingDone()
98 152 stub -noname IsSyncForegroundPolicyRefresh #stdcall -noname IsSyncForegroundPolicyRefresh(8)
99 153 stub -noname CreateUserProfileExA #stdcall -noname CreateUserProfileExA(24)
100 154 stub -noname CreateUserProfileExW #stdcall -noname CreateUserProfileExW(24)
101 155 stub -noname CopySystemProfile #stdcall -noname CopySystemProfile(4)
102 156 stub -noname GetUserProfileDirFromSidA #stdcall -noname GetUserProfileDirFromSidA(12)
103 157 stub -noname GetUserProfileDirFromSidW #stdcall -noname GetUserProfileDirFromSidW(12)
104 158 stub -noname SetNextFgPolicyRefreshInfo #stdcall -noname SetNextFgPolicyRefreshInfo(12)
105 159 stub -noname TranslateNameXForest #stdcall -noname TranslateNameXForest(20)
106 160 stub -noname AllocGpContainer #stdcall -noname AllocGpContainer(60)
107 161 stub -noname AddGPO #stdcall -noname AddGPO(84)
108 162 stub -noname GetWbemServices #stdcall -noname GetWbemServices(20)
109 163 stub -noname FilterGPOs #stdcall -noname FilterGPOs(8)
110 164 stub -noname ProcessMachAndUserGpoList #stdcall -noname ProcessMachAndUserGpoList(48)
111 165 stub -noname GPOExceptionFilter #stdcall -noname GPOExceptionFilter(4)
112 166 stub -noname LogExtSessionStatus #stdcall -noname LogExtSessionStatus(16)
113 167 stub -noname UpdateExtSessionStatus #stdcall -noname UpdateExtSessionStatus(16)
114 168 stub -noname UnloadGPExtensions #stdcall -noname UnloadGPExtensions(4)
115 169 stub -noname FreeGpoInfo #stdcall -noname FreeGpoInfo(4)
116 170 stub -noname LogSessionData #stdcall -noname LogSessionData(8)
117 171 stub -noname LogGpoData #stdcall -noname LogGpoData(4)
118 172 stub -noname ReadGPExtensions #stdcall -noname ReadGPExtensions(4)
119 173 stub -noname CheckForSkippedExtensions #stdcall -noname CheckForSkippedExtensions(8)
120 174 stub -noname SetupGPOFilter #stdcall -noname SetupGPOFilter(4)
121 175 stub -noname CheckXForestLogon #stdcall -noname CheckXForestLogon(4)
122 200 stub -noname CreateURLFile #stdcall -noname CreateURLFile(36)
123 201 stub -noname DeleteURLFile #stdcall -noname DeleteURLFile(16)