modified dll/win32/kernel32/misc/lang.c
[reactos.git] / reactos / lib / 3rdparty / icu4ros / icu / debian / libicu.postinst
1 #! /bin/sh
2 # Copyright (c) 2000-2003 International Business Machines
3 # Corporation and others. All Rights Reserved.
4 # postinst script for foo
5 #
6 # see: dh_installdeb(1)
7
8 set -e
9
10 # summary of how this script can be called:
11 # * <postinst> `configure' <most-recently-configured-version>
12 # * <old-postinst> `abort-upgrade' <new version>
13 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
14 # <new-version>
15 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
16 # <failed-install-package> <version> `removing'
17 # <conflicting-package> <version>
18 # for details, see /usr/share/doc/packaging-manual/
19 #
20 # quoting from the policy:
21 # Any necessary prompting should almost always be confined to the
22 # post-installation script, and should be protected with a conditional
23 # so that unnecessary prompting doesn't happen if a package's
24 # installation fails and the `postinst' is called with `abort-upgrade',
25 # `abort-remove' or `abort-deconfigure'.
26
27 # Call ldconfig in a way that makes lintian happy.
28
29 if [ "$1" = "configure" ]; then ldconfig; fi
30
31 # And now do the rest of the configuration
32
33 case "$1" in
34 configure)
35
36 # Adjust the current ICU link in /usr/lib/icu
37
38 if [ -d /usr/lib/icu ]
39 then
40
41 icucurrent=`2>/dev/null ls -dp /usr/lib/icu/* | sed -n 's,.*/\([^/]*\)/$,\1,p'| sort -rn | head -1`
42 cd /usr/lib/icu
43 rm -f current
44 if test x"$icucurrent" != x
45 then
46 ln -s "$icucurrent" current
47 ln -sf current/Makefile.inc .
48 fi
49
50 fi
51 ;;
52
53 abort-upgrade|abort-remove|abort-deconfigure)
54
55 ;;
56
57 *)
58 echo "postinst called with unknown argument \`$1'" >&2
59 exit 0
60 ;;
61 esac
62
63 # dh_installdeb will replace this with shell code automatically
64 # generated by other debhelper scripts.
65
66 #DEBHELPER#
67
68 exit 0
69
70