modified dll/win32/kernel32/misc/lang.c
[reactos.git] / reactos / lib / 3rdparty / icu4ros / icu / debian / rules
1 #!/usr/bin/make -f
2 #
3 # Copyright (c) 2000-2006 International Business Machines
4 # Corporation and others. All Rights Reserved.
5 #
6 # To distinguish variables that are truly local to this file (rather
7 # than for use by cdbs), we adopt the convention of starting local
8 # variables' names with l_.
9
10 l_PWD := $(shell pwd)
11 l_STAMPS := debian/l_stamps
12 l_RUN_CHECK := 1
13
14 # Variables used by cdbs
15
16 VERSION := $(shell dpkg-parsechangelog | \
17 awk '/Version:/ {print $$2}' | cut -d- -f 1)
18
19 DEB_TAR_SRCDIR = icu/source
20 DEB_CONFIGURE_USER_FLAGS = --disable-samples --enable-static
21 DEB_COMPRESS_EXCLUDE = html examples
22 DEB_INSTALL_EXAMPLES_libicu36-dev = \
23 build-tree/$(DEB_TAR_SRCDIR)/samples/*
24 # Include cdbs rules files.
25 include /usr/share/cdbs/1/rules/tarball.mk
26 include /usr/share/cdbs/1/rules/simple-patchsys.mk
27 include /usr/share/cdbs/1/rules/debhelper.mk
28 include /usr/share/cdbs/1/class/autotools.mk
29
30 DEB_MAKE_INSTALL_TARGET += install-doc
31
32 cleanbuilddir::
33 $(RM) -r $(l_STAMPS)
34
35 # As 0.4.21, cdbs creates but doesn't remove debian/compat. It
36 # creates it conditionally, so this doesn't have a trivial fix.
37 clean::
38 $(RM) debian/compat *.cdbs-config_list
39
40 # As per upstream, icuswap is deprecated and should not be
41 # distributed.
42 binary-post-install/libicu36-dev::
43 find debian/$(cdbs_curpkg) -type f -name .cvsignore | xargs rm
44 rm debian/$(cdbs_curpkg)/usr/sbin/icuswap
45
46 # Install lintian override files
47 binary-post-install/%::
48 if [ -f debian/$*.lintian ]; then \
49 mkdir -p debian/$*/usr/share/lintian/overrides && \
50 cp -p debian/$*.lintian debian/$*/usr/share/lintian/overrides/$*; \
51 fi