stub for NetServerGetInfo
[reactos.git] / reactos / lib / netapi32 / netapi32.spec
1 @ stub I_BrowserDebugCall
2 @ stub I_BrowserDebugTrace
3 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr)
4 @ stub I_BrowserQueryOtherDomains
5 @ stub I_BrowserQueryStatistics
6 @ stub I_BrowserResetNetlogonState
7 @ stub I_BrowserResetStatistics
8 @ stub I_BrowserServerEnum
9 @ stdcall I_BrowserSetNetlogonState(wstr wstr wstr long)
10 @ stub I_NetAccountDeltas
11 @ stub I_NetAccountSync
12 @ stub I_NetDatabaseDeltas
13 @ stub I_NetDatabaseRedo
14 @ stub I_NetDatabaseSync
15 @ stub I_NetDatabaseSync2
16 @ stub I_NetDfsCreateExitPoint
17 @ stub I_NetDfsCreateLocalPartition
18 @ stub I_NetDfsDeleteExitPoint
19 @ stub I_NetDfsDeleteLocalPartition
20 @ stub I_NetDfsFixLocalVolume
21 @ stub I_NetDfsGetVersion
22 @ stub I_NetDfsIsThisADomainName
23 @ stub I_NetDfsModifyPrefix
24 @ stub I_NetDfsSetLocalVolumeState
25 @ stub I_NetDfsSetServerInfo
26 @ stub I_NetGetDCList
27 @ stub I_NetListCanonicalize
28 @ stub I_NetListTraverse
29 @ stub I_NetLogonControl
30 @ stub I_NetLogonControl2
31 @ stub I_NetLogonSamLogoff
32 @ stub I_NetLogonSamLogon
33 @ stub I_NetLogonUasLogoff
34 @ stub I_NetLogonUasLogon
35 @ stub I_NetNameCanonicalize
36 @ stub I_NetNameCompare
37 @ stub I_NetNameValidate
38 @ stub I_NetPathCanonicalize
39 @ stub I_NetPathCompare
40 @ stub I_NetPathType
41 @ stub I_NetServerAuthenticate
42 @ stub I_NetServerAuthenticate2
43 @ stub I_NetServerPasswordSet
44 @ stub I_NetServerReqChallenge
45 @ stub I_NetServerSetServiceBits
46 @ stub I_NetServerSetServiceBitsEx
47 @ stub NetAlertRaise
48 @ stub NetAlertRaiseEx
49 @ stdcall NetApiBufferAllocate(long ptr)
50 @ stdcall NetApiBufferFree(ptr)
51 @ stdcall NetApiBufferReallocate(ptr long ptr)
52 @ stdcall NetApiBufferSize(ptr ptr)
53 @ stub NetAuditClear
54 @ stub NetAuditRead
55 @ stub NetAuditWrite
56 @ stub NetBrowserStatisticsGet
57 @ stub NetConfigGet
58 @ stub NetConfigGetAll
59 @ stub NetConfigSet
60 @ stub NetConnectionEnum
61 @ stub NetDfsAdd
62 @ stub NetDfsEnum
63 @ stub NetDfsGetInfo
64 @ stub NetDfsManagerGetConfigInfo
65 @ stub NetDfsMove
66 @ stub NetDfsRemove
67 @ stub NetDfsRename
68 @ stub NetDfsSetInfo
69 @ stub NetEnumerateTrustedDomains
70 @ stub NetErrorLogClear
71 @ stub NetErrorLogRead
72 @ stub NetErrorLogWrite
73 @ stub NetFileClose
74 @ stub NetFileEnum
75 @ stub NetFileGetInfo
76 @ stub NetGetAnyDCName
77 @ stdcall NetGetDCName(wstr wstr ptr)
78 @ stub NetGetDisplayInformationIndex
79 @ stub NetGroupAdd
80 @ stub NetGroupAddUser
81 @ stub NetGroupDel
82 @ stub NetGroupDelUser
83 @ stub NetGroupEnum
84 @ stub NetGroupGetInfo
85 @ stub NetGroupGetUsers
86 @ stub NetGroupSetInfo
87 @ stub NetGroupSetUsers
88 @ stdcall NetLocalGroupAdd(wstr long ptr ptr)
89 @ stub NetLocalGroupAddMember
90 @ stub NetLocalGroupAddMembers
91 @ stub NetLocalGroupDel
92 @ stub NetLocalGroupDelMember
93 @ stub NetLocalGroupDelMembers
94 @ stub NetLocalGroupEnum
95 @ stub NetLocalGroupGetInfo
96 @ stub NetLocalGroupGetMembers
97 @ stub NetLocalGroupSetInfo
98 @ stdcall NetLocalGroupSetMembers(wstr wstr long ptr ptr)
99 @ stub NetMessageBufferSend
100 @ stub NetMessageNameAdd
101 @ stub NetMessageNameDel
102 @ stub NetMessageNameEnum
103 @ stub NetMessageNameGetInfo
104 @ stdcall NetQueryDisplayInformation(wstr long long long long ptr ptr)
105 @ stub NetRemoteComputerSupports
106 @ stub NetRemoteTOD
107 @ stub NetReplExportDirAdd
108 @ stub NetReplExportDirDel
109 @ stub NetReplExportDirEnum
110 @ stub NetReplExportDirGetInfo
111 @ stub NetReplExportDirLock
112 @ stub NetReplExportDirSetInfo
113 @ stub NetReplExportDirUnlock
114 @ stub NetReplGetInfo
115 @ stub NetReplImportDirAdd
116 @ stub NetReplImportDirDel
117 @ stub NetReplImportDirEnum
118 @ stub NetReplImportDirGetInfo
119 @ stub NetReplImportDirLock
120 @ stub NetReplImportDirUnlock
121 @ stub NetReplSetInfo
122 @ stub NetRplAdapterAdd
123 @ stub NetRplAdapterDel
124 @ stub NetRplAdapterEnum
125 @ stub NetRplBootAdd
126 @ stub NetRplBootDel
127 @ stub NetRplBootEnum
128 @ stub NetRplClose
129 @ stub NetRplConfigAdd
130 @ stub NetRplConfigDel
131 @ stub NetRplConfigEnum
132 @ stub NetRplGetInfo
133 @ stub NetRplOpen
134 @ stub NetRplProfileAdd
135 @ stub NetRplProfileClone
136 @ stub NetRplProfileDel
137 @ stub NetRplProfileEnum
138 @ stub NetRplProfileGetInfo
139 @ stub NetRplProfileSetInfo
140 @ stub NetRplSetInfo
141 @ stub NetRplSetSecurity
142 @ stub NetRplVendorAdd
143 @ stub NetRplVendorDel
144 @ stub NetRplVendorEnum
145 @ stub NetRplWkstaAdd
146 @ stub NetRplWkstaClone
147 @ stub NetRplWkstaDel
148 @ stub NetRplWkstaEnum
149 @ stub NetRplWkstaGetInfo
150 @ stub NetRplWkstaSetInfo
151 @ stub NetScheduleJobAdd
152 @ stub NetScheduleJobDel
153 @ stub NetScheduleJobEnum
154 @ stub NetScheduleJobGetInfo
155 @ stub NetServerComputerNameAdd
156 @ stub NetServerComputerNameDel
157 @ stub NetServerDiskEnum
158 @ stdcall NetServerEnum(wstr long ptr long ptr ptr long wstr ptr)
159 @ stub NetServerEnumEx
160 @ stdcall NetServerGetInfo(wstr long ptr)
161 @ stub NetServerSetInfo
162 @ stub NetServerTransportAdd
163 @ stub NetServerTransportAddEx
164 @ stub NetServerTransportDel
165 @ stub NetServerTransportEnum
166 @ stub NetServiceControl
167 @ stub NetServiceEnum
168 @ stub NetServiceGetInfo
169 @ stub NetServiceInstall
170 @ stub NetSessionDel
171 @ stub NetSessionEnum
172 @ stub NetSessionGetInfo
173 @ stub NetShareAdd
174 @ stub NetShareCheck
175 @ stub NetShareDel
176 @ stub NetShareDelSticky
177 @ stdcall NetShareEnum(wstr long ptr long ptr ptr ptr)
178 @ stub NetShareEnumSticky
179 @ stub NetShareGetInfo
180 @ stub NetShareSetInfo
181 @ stdcall NetStatisticsGet(wstr wstr long long ptr)
182 @ stub NetUseAdd
183 @ stub NetUseDel
184 @ stub NetUseEnum
185 @ stub NetUseGetInfo
186 @ stub NetUserAdd
187 @ stub NetUserChangePassword
188 @ stub NetUserDel
189 @ stdcall NetUserEnum(wstr long long ptr long ptr ptr ptr)
190 @ stub NetUserGetGroups
191 @ stdcall NetUserGetInfo(wstr wstr long ptr)
192 @ stub NetUserGetLocalGroups
193 @ stdcall NetUserModalsGet(wstr long ptr)
194 @ stub NetUserModalsSet
195 @ stub NetUserSetGroups
196 @ stub NetUserSetInfo
197 @ stdcall NetWkstaGetInfo(wstr long ptr)
198 @ stub NetWkstaSetInfo
199 @ stub NetWkstaTransportAdd
200 @ stub NetWkstaTransportDel
201 @ stdcall NetWkstaTransportEnum (wstr long ptr long ptr ptr ptr)
202 @ stub NetWkstaUserEnum
203 @ stdcall NetWkstaUserGetInfo(wstr long ptr)
204 @ stub NetWkstaUserSetInfo
205 @ stdcall NetapipBufferAllocate(long ptr) NetApiBufferAllocate
206 @ stdcall Netbios(ptr)
207 @ stub NetpAccessCheck
208 @ stub NetpAccessCheckAndAudit
209 @ stub NetpAllocConfigName
210 @ stub NetpAllocStrFromStr
211 @ stub NetpAllocStrFromWStr
212 @ stub NetpAllocTStrFromString
213 @ stub NetpAllocWStrFromStr
214 @ stub NetpAllocWStrFromWStr
215 @ stub NetpApiStatusToNtStatus
216 @ stub NetpAssertFailed
217 @ stub NetpCloseConfigData
218 @ stub NetpCopyStringToBuffer
219 @ stub NetpCreateSecurityObject
220 @ stub NetpDbgDisplayServerInfo
221 @ stub NetpDbgPrint
222 @ stdcall NetpDeleteSecurityObject(long) ntdll.RtlDeleteSecurityObject
223 @ stdcall NetpGetComputerName(ptr)
224 @ stub NetpGetConfigBool
225 @ stub NetpGetConfigDword
226 @ stub NetpGetConfigTStrArray
227 @ stub NetpGetConfigValue
228 @ stub NetpGetDomainName
229 @ stub NetpGetFileSecurity
230 @ stub NetpGetPrivilege
231 @ stub NetpHexDump
232 @ stdcall NetpInitOemString(ptr str) ntdll.RtlInitAnsiString
233 @ stub NetpIsRemote
234 @ stub NetpIsUncComputerNameValid
235 @ stub NetpLocalTimeZoneOffset
236 @ stub NetpLogonPutUnicodeString
237 @ stub NetpNetBiosAddName
238 @ stub NetpNetBiosCall
239 @ stub NetpNetBiosDelName
240 @ stub NetpNetBiosGetAdapterNumbers
241 @ stub NetpNetBiosHangup
242 @ stub NetpNetBiosReceive
243 @ stub NetpNetBiosReset
244 @ stub NetpNetBiosSend
245 @ stub NetpNetBiosStatusToApiStatus
246 @ stub NetpNtStatusToApiStatus
247 @ stub NetpOpenConfigData
248 @ stub NetpPackString
249 @ stub NetpReleasePrivilege
250 @ stub NetpSetConfigBool
251 @ stub NetpSetConfigDword
252 @ stub NetpSetConfigTStrArray
253 @ stub NetpSetFileSecurity
254 @ stub NetpSmbCheck
255 @ stub NetpStringToNetBiosName
256 @ stub NetpTStrArrayEntryCount
257 @ stub NetpwNameCanonicalize
258 @ stub NetpwNameCompare
259 @ stub NetpwNameValidate
260 @ stub NetpwPathCanonicalize
261 @ stub NetpwPathCompare
262 @ stub NetpwPathType
263 @ stub NlBindingAddServerToCache
264 @ stub NlBindingRemoveServerFromCache
265 @ stub NlBindingSetAuthInfo
266 @ stub RxNetAccessAdd
267 @ stub RxNetAccessDel
268 @ stub RxNetAccessEnum
269 @ stub RxNetAccessGetInfo
270 @ stub RxNetAccessGetUserPerms
271 @ stub RxNetAccessSetInfo
272 @ stub RxNetServerEnum
273 @ stub RxNetUserPasswordSet
274 @ stub RxRemoteApi