Copy makefile
[reactos.git] / reactos / lib / rpcrt4 / rpcrt4.spec
1 @ stdcall DceErrorInqTextA (long ptr)
2 @ stdcall DceErrorInqTextW (long ptr)
3 @ stdcall -private DllRegisterServer() RPCRT4_DllRegisterServer
4
5 @ stub MesBufferHandleReset
6 @ stub MesDecodeBufferHandleCreate
7 @ stub MesDecodeIncrementalHandleCreate
8 @ stub MesEncodeDynBufferHandleCreate
9 @ stub MesEncodeFixedBufferHandleCreate
10 @ stub MesEncodeIncrementalHandleCreate
11 @ stub MesHandleFree
12 @ stub MesIncrementalHandleReset
13 @ stub MesInqProcEncodingId
14
15 @ stub MqGetContext # win9x
16 @ stub MqRegisterQueue # win9x
17
18 @ stub RpcAbortAsyncCall
19 @ stub RpcAsyncAbortCall
20 @ stub RpcAsyncCancelCall
21 @ stub RpcAsyncCompleteCall
22 @ stub RpcAsyncGetCallStatus
23 @ stub RpcAsyncInitializeHandle
24 @ stub RpcAsyncRegisterInfo
25 @ stub RpcBindingCopy
26 @ stdcall RpcBindingFree(ptr)
27 @ stdcall RpcBindingFromStringBindingA(str ptr)
28 @ stdcall RpcBindingFromStringBindingW(wstr ptr)
29 @ stub RpcBindingInqAuthClientA
30 @ stub RpcBindingInqAuthClientW
31 @ stub RpcBindingInqAuthClientExA
32 @ stub RpcBindingInqAuthClientExW
33 @ stub RpcBindingInqAuthInfoA
34 @ stub RpcBindingInqAuthInfoW
35 @ stub RpcBindingInqAuthInfoExA
36 @ stub RpcBindingInqAuthInfoExW
37 @ stdcall RpcBindingInqObject(ptr ptr)
38 @ stub RpcBindingInqOption
39 @ stub RpcBindingReset
40 @ stub RpcBindingServerFromClient
41 @ stub RpcBindingSetAuthInfoA
42 @ stub RpcBindingSetAuthInfoW
43 @ stub RpcBindingSetAuthInfoExA
44 @ stub RpcBindingSetAuthInfoExW
45 @ stdcall RpcBindingSetObject(ptr ptr)
46 @ stub RpcBindingSetOption
47 @ stdcall RpcBindingToStringBindingA(ptr ptr)
48 @ stdcall RpcBindingToStringBindingW(ptr ptr)
49 @ stdcall RpcBindingVectorFree(ptr)
50 @ stub RpcCancelAsyncCall
51 @ stub RpcCancelThread
52 @ stub RpcCancelThreadEx
53 @ stub RpcCertGeneratePrincipalNameA
54 @ stub RpcCertGeneratePrincipalNameW
55 @ stub RpcCompleteAsyncCall
56 @ stdcall RpcEpRegisterA(ptr ptr ptr str)
57 @ stub RpcEpRegisterW
58 @ stub RpcEpRegisterNoReplaceA
59 @ stub RpcEpRegisterNoReplaceW
60 @ stdcall RpcEpResolveBinding(ptr ptr)
61 @ stdcall RpcEpUnregister(ptr ptr ptr)
62 @ stub RpcErrorAddRecord # wxp
63 @ stub RpcErrorClearInformation # wxp
64 @ stub RpcErrorEndEnumeration # wxp
65 @ stub RpcErrorGetNextRecord # wxp
66 @ stub RpcErrorNumberOfRecords # wxp
67 @ stub RpcErrorLoadErrorInfo # wxp
68 @ stub RpcErrorResetEnumeration # wxp
69 @ stub RpcErrorSaveErrorInfo # wxp
70 @ stub RpcErrorStartEnumeration # wxp
71 @ stub RpcFreeAuthorizationContext # wxp
72 @ stub RpcGetAsyncCallStatus
73 @ stub RpcIfIdVectorFree
74 @ stub RpcIfInqId
75 @ stub RpcImpersonateClient
76 @ stub RpcInitializeAsyncHandle
77 @ stub RpcMgmtBindingInqParameter # win9x
78 @ stub RpcMgmtBindingSetParameter # win9x
79 @ stub RpcMgmtEnableIdleCleanup
80 @ stub RpcMgmtEpEltInqBegin
81 @ stub RpcMgmtEpEltInqDone
82 @ stub RpcMgmtEpEltInqNextA
83 @ stub RpcMgmtEpEltInqNextW
84 @ stub RpcMgmtEpUnregister
85 @ stub RpcMgmtInqComTimeout
86 @ stub RpcMgmtInqDefaultProtectLevel
87 @ stub RpcMgmtInqIfIds
88 @ stub RpcMgmtInqParameter # win9x
89 @ stub RpcMgmtInqServerPrincNameA
90 @ stub RpcMgmtInqServerPrincNameW
91 @ stub RpcMgmtInqStats
92 @ stub RpcMgmtIsServerListening
93 @ stub RpcMgmtSetAuthorizationFn
94 @ stub RpcMgmtSetCancelTimeout
95 @ stub RpcMgmtSetComTimeout
96 @ stub RpcMgmtSetParameter # win9x
97 @ stub RpcMgmtSetServerStackSize
98 @ stub RpcMgmtStatsVectorFree
99 @ stdcall RpcMgmtStopServerListening(ptr)
100 @ stdcall RpcMgmtWaitServerListen()
101 @ stub RpcNetworkInqProtseqsA
102 @ stub RpcNetworkInqProtseqsW
103 @ stdcall RpcNetworkIsProtseqValidA(ptr)
104 @ stdcall RpcNetworkIsProtseqValidW(ptr)
105 @ stub RpcNsBindingInqEntryNameA
106 @ stub RpcNsBindingInqEntryNameW
107 @ stub RpcObjectInqType
108 @ stub RpcObjectSetInqFn
109 @ stdcall RpcObjectSetType(ptr ptr)
110 @ stub RpcProtseqVectorFreeA
111 @ stub RpcProtseqVectorFreeW
112 @ stdcall RpcRaiseException(long)
113 @ stub RpcRegisterAsyncInfo
114 @ stub RpcRevertToSelf
115 @ stub RpcRevertToSelfEx
116 @ stdcall RpcServerInqBindings(ptr)
117 @ stub RpcServerInqCallAttributesA # wxp
118 @ stub RpcServerInqCallAttributesW # wxp
119 @ stub RpcServerInqDefaultPrincNameA
120 @ stub RpcServerInqDefaultPrincNameW
121 @ stub RpcServerInqIf
122 @ stdcall RpcServerListen(long long long)
123 @ stdcall RpcServerRegisterAuthInfoA(str long ptr ptr)
124 @ stdcall RpcServerRegisterAuthInfoW(wstr long ptr ptr)
125 @ stdcall RpcServerRegisterIf(ptr ptr ptr)
126 @ stdcall RpcServerRegisterIfEx(ptr ptr ptr long long ptr)
127 @ stdcall RpcServerRegisterIf2(ptr ptr ptr long long long ptr)
128 @ stub RpcServerTestCancel
129 @ stdcall RpcServerUnregisterIf(ptr ptr long)
130 @ stdcall RpcServerUnregisterIfEx(ptr ptr long)
131 @ stub RpcServerUseAllProtseqs
132 @ stub RpcServerUseAllProtseqsEx
133 @ stub RpcServerUseAllProtseqsIf
134 @ stub RpcServerUseAllProtseqsIfEx
135 @ stdcall RpcServerUseProtseqA(str long ptr)
136 @ stdcall RpcServerUseProtseqW(wstr long ptr)
137 @ stub RpcServerUseProtseqExA
138 @ stub RpcServerUseProtseqExW
139 @ stdcall RpcServerUseProtseqEpA(str long str ptr)
140 @ stdcall RpcServerUseProtseqEpW(wstr long wstr ptr)
141 @ stdcall RpcServerUseProtseqEpExA(str long str ptr ptr)
142 @ stdcall RpcServerUseProtseqEpExW(wstr long wstr ptr ptr)
143 @ stub RpcServerUseProtseqIfA
144 @ stub RpcServerUseProtseqIfW
145 @ stub RpcServerUseProtseqIfExA
146 @ stub RpcServerUseProtseqIfExW
147 @ stub RpcServerYield
148 @ stub RpcSmAllocate
149 @ stub RpcSmClientFree
150 @ stub RpcSmDestroyClientContext
151 @ stub RpcSmDisableAllocate
152 @ stub RpcSmEnableAllocate
153 @ stub RpcSmFree
154 @ stub RpcSmGetThreadHandle
155 @ stub RpcSmSetClientAllocFree
156 @ stub RpcSmSetThreadHandle
157 @ stub RpcSmSwapClientAllocFree
158 @ stub RpcSsAllocate
159 @ stub RpcSsContextLockExclusive # wxp
160 @ stub RpcSsContextLockShared # wxp
161 @ stub RpcSsDestroyClientContext
162 @ stub RpcSsDisableAllocate
163 @ stub RpcSsDontSerializeContext
164 @ stub RpcSsEnableAllocate
165 @ stub RpcSsFree
166 @ stub RpcSsGetContextBinding
167 @ stub RpcSsGetThreadHandle
168 @ stub RpcSsSetClientAllocFree
169 @ stub RpcSsSetThreadHandle
170 @ stub RpcSsSwapClientAllocFree
171 @ stdcall RpcStringBindingComposeA(str str str str str ptr)
172 @ stdcall RpcStringBindingComposeW(wstr wstr wstr wstr wstr ptr)
173 @ stdcall RpcStringBindingParseA(str ptr ptr ptr ptr ptr)
174 @ stdcall RpcStringBindingParseW(wstr ptr ptr ptr ptr ptr)
175 @ stdcall RpcStringFreeA(ptr)
176 @ stdcall RpcStringFreeW(ptr)
177 @ stub RpcTestCancel
178 @ stub RpcUserFree # wxp
179
180 @ stub TowerConstruct
181 @ stub TowerExplode
182
183 @ stub SimpleTypeAlignment # wxp
184 @ stub SimpleTypeBufferSize # wxp
185 @ stub SimpleTypeMemorySize # wxp
186
187 @ stub pfnFreeRoutines # wxp
188 @ stub pfnMarshallRouteines # wxp
189 @ stub pfnSizeRoutines # wxp
190 @ stub pfnUnmarshallRouteines # wxp
191
192 @ stdcall UuidCompare(ptr ptr ptr)
193 @ stdcall UuidCreate(ptr)
194 @ stdcall UuidCreateSequential(ptr) # win 2000
195 @ stdcall UuidCreateNil(ptr)
196 @ stdcall UuidEqual(ptr ptr ptr)
197 @ stdcall UuidFromStringA(str ptr)
198 @ stdcall UuidFromStringW(wstr ptr)
199 @ stdcall UuidHash(ptr ptr)
200 @ stdcall UuidIsNil(ptr ptr)
201 @ stdcall UuidToStringA(ptr ptr)
202 @ stdcall UuidToStringW(ptr ptr)
203
204 @ stdcall CStdStubBuffer_QueryInterface(ptr ptr ptr)
205 @ stdcall CStdStubBuffer_AddRef(ptr)
206 @ stdcall CStdStubBuffer_Connect(ptr ptr)
207 @ stdcall CStdStubBuffer_Disconnect(ptr)
208 @ stdcall CStdStubBuffer_Invoke(ptr ptr ptr)
209 @ stdcall CStdStubBuffer_IsIIDSupported(ptr ptr)
210 @ stdcall CStdStubBuffer_CountRefs(ptr)
211 @ stdcall CStdStubBuffer_DebugServerQueryInterface(ptr ptr)
212 @ stdcall CStdStubBuffer_DebugServerRelease(ptr ptr)
213 @ stdcall NdrCStdStubBuffer_Release(ptr ptr)
214 @ stub NdrCStdStubBuffer2_Release
215
216 @ stdcall IUnknown_QueryInterface_Proxy(ptr ptr ptr)
217 @ stdcall IUnknown_AddRef_Proxy(ptr)
218 @ stdcall IUnknown_Release_Proxy(ptr)
219
220 @ stdcall NdrDllCanUnloadNow(ptr)
221 @ stdcall NdrDllGetClassObject(ptr ptr ptr ptr ptr ptr)
222 @ stdcall NdrDllRegisterProxy(long ptr ptr)
223 @ stdcall NdrDllUnregisterProxy(long ptr ptr)
224
225 @ stdcall NdrAllocate(ptr long)
226 @ stub NdrAsyncClientCall
227 @ stub NdrAsyncServerCall
228 @ stdcall NdrClearOutParameters(ptr ptr ptr)
229 @ stub NdrClientCall
230 @ varargs NdrClientCall2(ptr ptr)
231 @ stub NdrClientInitialize
232 @ stdcall NdrClientInitializeNew(ptr ptr ptr long)
233 @ stub NdrContextHandleInitialize
234 @ stub NdrContextHandleSize
235 @ stdcall NdrConvert(ptr ptr)
236 @ stdcall NdrConvert2(ptr ptr long)
237 @ stub NdrCorrelationFree
238 @ stub NdrCorrelationInitialize
239 @ stub NdrCorrelationPass
240 @ stub CreateServerInterfaceFromStub # wxp
241 @ stub NdrDcomAsyncClientCall
242 @ stub NdrDcomAsyncStubCall
243 @ stdcall NdrFreeBuffer(ptr)
244 @ stub NdrFullPointerFree
245 @ stub NdrFullPointerInsertRefId
246 @ stub NdrFullPointerQueryPointer
247 @ stub NdrFullPointerQueryRefId
248 @ stub NdrFullPointerXlatFree
249 @ stub NdrFullPointerXlatInit
250 @ stdcall NdrGetBuffer(ptr long ptr)
251 @ stub NdrGetDcomProtocolVersion
252 @ stub NdrGetSimpleTypeBufferAlignment # wxp
253 @ stub NdrGetSimpleTypeBufferSize # wxp
254 @ stub NdrGetSimpleTypeMemorySize # wxp
255 @ stub NdrGetTypeFlags # wxp
256 @ stub NdrGetPartialBuffer
257 @ stub NdrGetPipeBuffer
258 @ stub NdrGetUserMarshallInfo
259 @ stub NdrIsAppDoneWithPipes
260 @ stub NdrMapCommAndFaultStatus
261 @ stub NdrMarkNextActivePipe
262 @ stub NdrMesProcEncodeDecode
263 @ stub NdrMesProcEncodeDecode2
264 @ stub NdrMesSimpleTypeAlignSize
265 @ stub NdrMesSimpleTypeDecode
266 @ stub NdrMesSimpleTypeEncode
267 @ stub NdrMesTypeAlignSize
268 @ stub NdrMesTypeAlignSize2
269 @ stub NdrMesTypeDecode
270 @ stub NdrMesTypeDecode2
271 @ stub NdrMesTypeEncode
272 @ stub NdrMesTypeEncode2
273 @ stub NdrMesTypeFree2
274 @ stub NdrNsGetBuffer
275 @ stub NdrNsSendReceive
276 @ stdcall NdrOleAllocate(long)
277 @ stdcall NdrOleFree(ptr)
278 @ stub NdrOutInit # wxp
279 @ stub NdrPartialIgnoreClientBufferSize # wxp
280 @ stub NdrPartialIgnoreClientMarshall # wxp
281 @ stub NdrPartialIgnoreServerInitialize # wxp
282 @ stub NdrPartialIgnoreServerUnmarshall # wxp
283 @ stub NdrPipePull
284 @ stub NdrPipePush
285 @ stub NdrPipeSendReceive
286 @ stub NdrPipesDone
287 @ stub NdrPipesInitialize
288 @ stdcall NdrProxyErrorHandler(long)
289 @ stdcall NdrProxyFreeBuffer(ptr ptr)
290 @ stdcall NdrProxyGetBuffer(ptr ptr)
291 @ stdcall NdrProxyInitialize(ptr ptr ptr ptr long)
292 @ stdcall NdrProxySendReceive(ptr ptr)
293 @ stub NdrRangeUnmarshall
294 @ stub NdrRpcSmClientAllocate
295 @ stub NdrRpcSmClientFree
296 @ stub NdrRpcSmSetClientToOsf
297 @ stub NdrRpcSsDefaultAllocate
298 @ stub NdrRpcSsDefaultFree
299 @ stub NdrRpcSsDisableAllocate
300 @ stub NdrRpcSsEnableAllocate
301 @ stdcall NdrSendReceive(ptr ptr)
302 @ stub NdrServerCall
303 @ stub NdrServerCall2
304 @ stub NdrStubCall
305 @ stub NdrStubCall2
306 @ stub NdrStubForwardingFunction
307 @ stdcall NdrStubGetBuffer(ptr ptr ptr)
308 @ stdcall NdrStubInitialize(ptr ptr ptr ptr)
309 @ stub NdrStubInitializeMarshall
310 @ stub NdrpCreateProxy # wxp
311 @ stub NdrpCreateStub # wxp
312 @ stub NdrpGetProcFormatString # wxp
313 @ stub NdrpGetTypeFormatString # wxp
314 @ stub NdrpGetTypeGenCookie # wxp
315 @ stub NdrpMemoryIncrement # wxp
316 @ stub NdrpReleaseTypeFormatString # wxp
317 @ stub NdrpReleaseTypeGenCookie # wxp
318 @ stub NdrpSetRpcSsDefaults
319 @ stub NdrpVarVtOfTypeDesc # wxp
320 @ stub NdrTypeFlags # wxp
321 @ stub NdrTypeFree # wxp
322 @ stub NdrTypeMarshall # wxp
323 @ stub NdrTypeSize # wxp
324 @ stub NdrTypeUnmarshall # wxp
325 @ stub NdrUnmarshallBasetypeInline # wxp
326
327 @ stub NdrByteCountPointerBufferSize
328 @ stub NdrByteCountPointerFree
329 @ stub NdrByteCountPointerMarshall
330 @ stub NdrByteCountPointerUnmarshall
331 @ stub NdrClientContextMarshall
332 @ stub NdrClientContextUnmarshall
333 @ stdcall NdrComplexArrayBufferSize(ptr ptr ptr)
334 @ stdcall NdrComplexArrayFree(ptr ptr ptr)
335 @ stdcall NdrComplexArrayMarshall(ptr ptr ptr)
336 @ stdcall NdrComplexArrayMemorySize(ptr ptr)
337 @ stdcall NdrComplexArrayUnmarshall(ptr ptr ptr long)
338 @ stdcall NdrComplexStructBufferSize(ptr ptr ptr)
339 @ stdcall NdrComplexStructFree(ptr ptr ptr)
340 @ stdcall NdrComplexStructMarshall(ptr ptr ptr)
341 @ stdcall NdrComplexStructMemorySize(ptr ptr)
342 @ stdcall NdrComplexStructUnmarshall(ptr ptr ptr long)
343 @ stdcall NdrConformantArrayBufferSize(ptr ptr ptr)
344 @ stdcall NdrConformantArrayFree(ptr ptr ptr)
345 @ stdcall NdrConformantArrayMarshall(ptr ptr ptr)
346 @ stdcall NdrConformantArrayMemorySize(ptr ptr)
347 @ stdcall NdrConformantArrayUnmarshall(ptr ptr ptr long)
348 @ stdcall NdrConformantStringBufferSize(ptr ptr ptr)
349 @ stdcall NdrConformantStringMarshall(ptr ptr ptr)
350 @ stdcall NdrConformantStringMemorySize(ptr ptr)
351 @ stdcall NdrConformantStringUnmarshall(ptr ptr ptr long)
352 @ stub NdrConformantStructBufferSize
353 @ stub NdrConformantStructFree
354 @ stub NdrConformantStructMarshall
355 @ stub NdrConformantStructMemorySize
356 @ stub NdrConformantStructUnmarshall
357 @ stdcall NdrConformantVaryingArrayBufferSize(ptr ptr ptr)
358 @ stdcall NdrConformantVaryingArrayFree(ptr ptr ptr)
359 @ stdcall NdrConformantVaryingArrayMarshall(ptr ptr ptr)
360 @ stdcall NdrConformantVaryingArrayMemorySize(ptr ptr)
361 @ stdcall NdrConformantVaryingArrayUnmarshall(ptr ptr ptr long)
362 @ stub NdrConformantVaryingStructBufferSize
363 @ stub NdrConformantVaryingStructFree
364 @ stub NdrConformantVaryingStructMarshall
365 @ stub NdrConformantVaryingStructMemorySize
366 @ stub NdrConformantVaryingStructUnmarshall
367 @ stub NdrEncapsulatedUnionBufferSize
368 @ stub NdrEncapsulatedUnionFree
369 @ stub NdrEncapsulatedUnionMarshall
370 @ stub NdrEncapsulatedUnionMemorySize
371 @ stub NdrEncapsulatedUnionUnmarshall
372 @ stub NdrFixedArrayBufferSize
373 @ stub NdrFixedArrayFree
374 @ stub NdrFixedArrayMarshall
375 @ stub NdrFixedArrayMemorySize
376 @ stub NdrFixedArrayUnmarshall
377 @ stub NdrHardStructBufferSize
378 @ stub NdrHardStructFree
379 @ stub NdrHardStructMarshall
380 @ stub NdrHardStructMemorySize
381 @ stub NdrHardStructUnmarshall
382 @ stdcall NdrInterfacePointerBufferSize(ptr ptr ptr)
383 @ stdcall NdrInterfacePointerFree(ptr ptr ptr)
384 @ stdcall NdrInterfacePointerMarshall(ptr ptr ptr)
385 @ stdcall NdrInterfacePointerMemorySize(ptr ptr)
386 @ stdcall NdrInterfacePointerUnmarshall(ptr ptr ptr long)
387 @ stub NdrNonConformantStringBufferSize
388 @ stub NdrNonConformantStringMarshall
389 @ stub NdrNonConformantStringMemorySize
390 @ stub NdrNonConformantStringUnmarshall
391 @ stub NdrNonEncapsulatedUnionBufferSize
392 @ stub NdrNonEncapsulatedUnionFree
393 @ stub NdrNonEncapsulatedUnionMarshall
394 @ stub NdrNonEncapsulatedUnionMemorySize
395 @ stub NdrNonEncapsulatedUnionUnmarshall
396 @ stdcall NdrPointerBufferSize(ptr ptr ptr)
397 @ stdcall NdrPointerFree(ptr ptr ptr)
398 @ stdcall NdrPointerMarshall(ptr ptr ptr)
399 @ stdcall NdrPointerMemorySize(ptr ptr)
400 @ stdcall NdrPointerUnmarshall(ptr ptr ptr long)
401 @ stub NdrServerContextMarshall
402 @ stub NdrServerContextUnmarshall
403 @ stub NdrServerContextNewMarshall # wxp
404 @ stub NdrServerContextNewUnmarshall # wxp
405 @ stub NdrServerInitialize
406 @ stub NdrServerInitializeMarshall
407 @ stdcall NdrServerInitializeNew(ptr ptr ptr)
408 @ stub NdrServerInitializePartial # wxp
409 @ stub NdrServerInitializeUnmarshall
410 @ stub NdrServerMarshall
411 @ stub NdrServerUnmarshall
412 @ stdcall NdrSimpleStructBufferSize(ptr ptr ptr)
413 @ stdcall NdrSimpleStructFree(ptr ptr ptr)
414 @ stdcall NdrSimpleStructMarshall(ptr ptr ptr)
415 @ stdcall NdrSimpleStructMemorySize(ptr ptr)
416 @ stdcall NdrSimpleStructUnmarshall(ptr ptr ptr long)
417 @ stdcall NdrSimpleTypeMarshall(ptr ptr long)
418 @ stdcall NdrSimpleTypeUnmarshall(ptr ptr long)
419 @ stdcall NdrUserMarshalBufferSize(ptr ptr ptr)
420 @ stdcall NdrUserMarshalFree(ptr ptr ptr)
421 @ stdcall NdrUserMarshalMarshall(ptr ptr ptr)
422 @ stdcall NdrUserMarshalMemorySize(ptr ptr)
423 @ stub NdrUserMarshalSimpleTypeConvert
424 @ stdcall NdrUserMarshalUnmarshall(ptr ptr ptr long)
425 @ stub NdrVaryingArrayBufferSize
426 @ stub NdrVaryingArrayFree
427 @ stub NdrVaryingArrayMarshall
428 @ stub NdrVaryingArrayMemorySize
429 @ stub NdrVaryingArrayUnmarshall
430 @ stub NdrXmitOrRepAsBufferSize
431 @ stub NdrXmitOrRepAsFree
432 @ stub NdrXmitOrRepAsMarshall
433 @ stub NdrXmitOrRepAsMemorySize
434 @ stub NdrXmitOrRepAsUnmarshall
435
436 @ stub NDRCContextBinding
437 @ stub NDRCContextMarshall
438 @ stub NDRCContextUnmarshall
439 @ stub NDRSContextMarshall
440 @ stub NDRSContextUnmarshall
441 @ stub NDRSContextMarshallEx
442 @ stub NDRSContextUnmarshallEx
443 @ stub NDRSContextMarshall2
444 @ stub NDRSContextUnmarshall2
445 @ stub NDRcopy
446
447 @ stub MIDL_wchar_strcpy
448 @ stub MIDL_wchar_strlen
449 @ stub char_array_from_ndr
450 @ stub char_from_ndr
451 @ stub data_from_ndr
452 @ stub data_into_ndr
453 @ stub data_size_ndr
454 @ stub double_array_from_ndr
455 @ stub double_from_ndr
456 @ stub enum_from_ndr
457 @ stub float_array_from_ndr
458 @ stub float_from_ndr
459 @ stub long_array_from_ndr
460 @ stub long_from_ndr
461 @ stub long_from_ndr_temp
462 @ stub short_array_from_ndr
463 @ stub short_from_ndr
464 @ stub short_from_ndr_temp
465 @ stub tree_into_ndr
466 @ stub tree_peek_ndr
467 @ stub tree_size_ndr
468
469 @ stub I_RpcAbortAsyncCall
470 @ stub I_RpcAllocate
471 @ stub I_RpcAsyncAbortCall
472 @ stub I_RpcAsyncSendReceive # NT4
473 @ stub I_RpcAsyncSetHandle
474 @ stub I_RpcBCacheAllocate
475 @ stub I_RpcBCacheFree
476 @ stub I_RpcBindingCopy
477 @ stub I_RpcBindingInqConnId
478 @ stub I_RpcBindingInqDynamicEndPoint
479 @ stub I_RpcBindingInqDynamicEndPointA
480 @ stub I_RpcBindingInqDynamicEndPointW
481 @ stub I_RpcBindingInqLocalClientPID # wxp
482 @ stub I_RpcBindingInqSecurityContext
483 @ stub I_RpcBindingInqTransportType
484 @ stub I_RpcBindingInqWireIdForSnego
485 @ stub I_RpcBindingIsClientLocal
486 @ stub I_RpcBindingToStaticStringBindingW
487 @ stdcall I_RpcBindingSetAsync(ptr ptr)
488 # 9x version of I_RpcBindingSetAsync has 3 arguments, not 2
489 @ stub I_RpcClearMutex
490 @ stub I_RpcConnectionInqSockBuffSize
491 @ stub I_RpcConnectionInqSockBuffSize2
492 @ stub I_RpcConnectionSetSockBuffSize
493 @ stub I_RpcDeleteMutex
494 @ stub I_RpcEnableWmiTrace # wxp
495 @ stub I_RpcExceptionFilter # wxp
496 @ stub I_RpcFree
497 @ stdcall I_RpcFreeBuffer(ptr)
498 @ stub I_RpcFreePipeBuffer
499 @ stub I_RpcGetAssociationContext
500 @ stdcall I_RpcGetBuffer(ptr)
501 @ stub I_RpcGetBufferWithObject
502 @ stub I_RpcGetCurrentCallHandle
503 @ stub I_RpcGetExtendedError
504 @ stub I_RpcGetServerContextList
505 @ stub I_RpcGetThreadEvent # win9x
506 @ stub I_RpcGetThreadWindowHandle # win9x
507 @ stub I_RpcIfInqTransferSyntaxes
508 @ stub I_RpcLaunchDatagramReceiveThread # win9x
509 @ stub I_RpcLogEvent
510 @ stub I_RpcMapWin32Status
511 @ stub I_RpcMonitorAssociation
512 @ stub I_RpcNegotiateTransferSyntax # wxp
513 @ stub I_RpcNsBindingSetEntryName
514 @ stub I_RpcNsBindingSetEntryNameA
515 @ stub I_RpcNsBindingSetEntryNameW
516 @ stub I_RpcNsInterfaceExported
517 @ stub I_RpcNsInterfaceUnexported
518 @ stub I_RpcParseSecurity
519 @ stub I_RpcPauseExecution
520 @ stub I_RpcProxyNewConnection # wxp
521 @ stub I_RpcReallocPipeBuffer
522 @ stdcall I_RpcReceive(ptr)
523 @ stub I_RpcRequestMutex
524 @ stdcall I_RpcSend(ptr)
525 @ stdcall I_RpcSendReceive(ptr)
526 @ stub I_RpcServerAllocateIpPort
527 @ stub I_RpcServerInqAddressChangeFn
528 @ stub I_RpcServerInqLocalConnAddress # wxp
529 @ stub I_RpcServerInqTransportType
530 @ stub I_RpcServerRegisterForwardFunction
531 @ stub I_RpcServerSetAddressChangeFn
532 @ stdcall I_RpcServerStartListening(ptr) # win9x
533 @ stdcall I_RpcServerStopListening() # win9x
534 @ stub I_RpcServerUnregisterEndpointA # win9x
535 @ stub I_RpcServerUnregisterEndpointW # win9x
536 @ stub I_RpcServerUseProtseq2A
537 @ stub I_RpcServerUseProtseq2W
538 @ stub I_RpcServerUseProtseqEp2A
539 @ stub I_RpcServerUseProtseqEp2W
540 @ stub I_RpcSetAsyncHandle
541 @ stub I_RpcSetAssociationContext # win9x
542 @ stub I_RpcSetServerContextList
543 @ stub I_RpcSetThreadParams # win9x
544 @ stub I_RpcSetWMsgEndpoint # NT4
545 @ stub I_RpcSsDontSerializeContext
546 @ stub I_RpcSystemFunction001 # wxp (oh, brother!)
547 @ stub I_RpcStopMonitorAssociation
548 @ stub I_RpcTransCancelMigration # win9x
549 @ stub I_RpcTransClientMaxFrag # win9x
550 @ stub I_RpcTransClientReallocBuffer # win9x
551 @ stub I_RpcTransConnectionAllocatePacket
552 @ stub I_RpcTransConnectionFreePacket
553 @ stub I_RpcTransConnectionReallocPacket
554 @ stub I_RpcTransDatagramAllocate
555 @ stub I_RpcTransDatagramAllocate2
556 @ stub I_RpcTransDatagramFree
557 @ stub I_RpcTransGetAddressList
558 @ stub I_RpcTransGetThreadEvent
559 @ stub I_RpcTransIoCancelled
560 @ stub I_RpcTransMaybeMakeReceiveAny # win9x
561 @ stub I_RpcTransMaybeMakeReceiveDirect # win9x
562 @ stub I_RpcTransPingServer # win9x
563 @ stub I_RpcTransServerFindConnection # win9x
564 @ stub I_RpcTransServerFreeBuffer # win9x
565 @ stub I_RpcTransServerMaxFrag # win9x
566 @ stub I_RpcTransServerNewConnection
567 @ stub I_RpcTransServerProtectThread # win9x
568 @ stub I_RpcTransServerReallocBuffer # win9x
569 @ stub I_RpcTransServerReceiveDirectReady # win9x
570 @ stub I_RpcTransServerUnprotectThread # win9x
571 @ stub I_RpcTurnOnEEInfoPropagation # wxp
572 @ stdcall I_RpcWindowProc(ptr long long long) # win9x
573 @ stub I_RpcltDebugSetPDUFilter
574 @ stub I_UuidCreate
575
576 @ stdcall CreateProxyFromTypeInfo(ptr ptr ptr ptr ptr)
577 @ stub CreateStubFromTypeInfo
578 @ stub PerformRpcInitialization
579 @ stub StartServiceIfNecessary # win9x
580 @ stub GlobalMutexClearExternal
581 @ stub GlobalMutexRequestExternal