[CALC] Enable support for HTMLHELP (#1877)
[reactos.git] / base / applications / calc / CMakeLists.txt
index d187356..07104ff 100644 (file)
@@ -1,19 +1,23 @@
 
-add_definitions(-DDISABLE_HTMLHELP_SUPPORT=1)
-
-add_executable(calc 
-    about.c
+list(APPEND SOURCE
     convert.c
-    function.c
-    rpn.c
-    utl.c
+    fun_ieee.c
+    rpn_ieee.c
+    utl_ieee.c
     winmain.c
-    resource.rc)
+    htmlhelp.c
+    theme.c
+    calc.h)
 
+file(GLOB calc_rc_deps res/*.*)
+add_rc_deps(resource.rc ${calc_rc_deps})
+add_executable(calc ${SOURCE} resource.rc)
 set_module_type(calc win32gui UNICODE)
-add_importlibs(calc advapi32 user32 gdi32 msvcrt kernel32)
+add_importlibs(calc advapi32 comctl32 user32 shell32 gdi32 msvcrt kernel32)
+
 if(MSVC)
     add_importlibs(calc ntdll)
 endif()
-add_pch(calc calc.h)
+
+add_pch(calc calc.h SOURCE)
 add_cd_file(TARGET calc DESTINATION reactos/system32 FOR all)