* Sync with recent trunk (r52637).
[reactos.git] / base / applications / charmap / CMakeLists.txt
index 37398c0..3e5d1bc 100644 (file)
@@ -1,5 +1,6 @@
 
 set_unicode()
+set_rc_compiler()
 
 list(APPEND SOURCE
     about.c
@@ -8,14 +9,12 @@ list(APPEND SOURCE
     map.c
     charmap.rc)
 
-add_executable(charmap
-    ${CMAKE_CURRENT_BINARY_DIR}/charmap_precomp.h.gch
-    ${SOURCE})
-
-add_pch(charmap ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+add_executable(charmap ${SOURCE})
 
 set_module_type(charmap win32gui)
 
-add_importlibs(charmap user32 gdi32 comctl32 kernel32 msvcrt)
+add_importlibs(charmap msvcrt user32 gdi32 comctl32 kernel32)
+
+add_pch(charmap precomp.h)
 
-add_cab_target(charmap 1)
+add_cd_file(TARGET charmap DESTINATION reactos/system32 FOR all)