[SNDVOL32] Add the small line dialog
[reactos.git] / base / applications / charmap / CMakeLists.txt
index 9921e82..e576b74 100644 (file)
@@ -5,10 +5,11 @@ list(APPEND SOURCE
     lrgcell.c
     map.c
     settings.c
-    charmap.rc)
+    precomp.h)
 
-add_executable(charmap ${SOURCE})
+add_rc_deps(charmap.rc ${CMAKE_CURRENT_SOURCE_DIR}/res/charmap.ico)
+add_executable(charmap ${SOURCE} charmap.rc)
 set_module_type(charmap win32gui UNICODE)
 add_importlibs(charmap advapi32 user32 gdi32 comctl32 msvcrt kernel32)
-add_pch(charmap precomp.h)
+add_pch(charmap precomp.h SOURCE)
 add_cd_file(TARGET charmap DESTINATION reactos/system32 FOR all)