* Sync with recent trunk (r52637).
[reactos.git] / base / applications / logoff / CMakeLists.txt
index 35dd240..399db9f 100644 (file)
@@ -1,16 +1,12 @@
-add_definitions(-D_DLL -D__USE_CRTIMP)
 
 list(APPEND SOURCE
     misc.c
     logoff.c
     logoff.rc)
 
-add_executable(logoff ${CMAKE_CURRENT_BINARY_DIR}/logoff_precomp.h.gch ${SOURCE})
-
-add_pch(logoff ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+add_executable(logoff ${SOURCE})
 
 set_module_type(logoff win32cui)
-
 add_importlibs(logoff advapi32 user32 msvcrt kernel32)
-
-add_cab_target(logoff 1)
\ No newline at end of file
+add_pch(logoff precomp.h)
+add_cd_file(TARGET logoff DESTINATION reactos/system32 FOR all)