* Sync with trunk r64401.
[reactos.git] / base / applications / mscutils / servman / CMakeLists.txt
index d07d4aa..53fb2c3 100644 (file)
@@ -1,6 +1,4 @@
 
-set_unicode()
-
 list(APPEND SOURCE
     about.c
     control.c
@@ -21,14 +19,10 @@ list(APPEND SOURCE
     start.c
     stop.c
     stop_dependencies.c
-    servman.rc)
-
-add_executable(servman ${CMAKE_CURRENT_BINARY_DIR}/servman_precomp.h.gch ${SOURCE})
-
-add_pch(servman ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-
-set_module_type(servman win32gui)
+    precomp.h)
 
+add_executable(servman ${SOURCE} servman.rc)
+set_module_type(servman win32gui UNICODE)
 add_importlibs(servman user32 gdi32 advapi32 version comctl32 shell32 comdlg32 msvcrt kernel32)
-
-add_cab_target(servman 1)
+add_pch(servman precomp.h SOURCE)
+add_cd_file(TARGET servman DESTINATION reactos/system32 FOR all)