[CMAKE] Introduce the atl_classes interface library
[reactos.git] / base / applications / mspaint / CMakeLists.txt
index c5ba106..fcf694a 100644 (file)
@@ -2,8 +2,6 @@ project(MSPAINT)
 
 add_definitions(-DINITGUID)
 
-include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
-
 list(APPEND SOURCE
     dialogs.cpp
     dib.cpp
@@ -32,7 +30,7 @@ file(GLOB mspaint_rc_deps icons/*.*)
 add_rc_deps(rsrc.rc ${mspaint_rc_deps})
 add_executable(mspaint ${SOURCE} rsrc.rc)
 set_module_type(mspaint win32gui UNICODE)
-target_link_libraries(mspaint uuid cpprt)
+target_link_libraries(mspaint uuid cpprt atl_classes)
 set_target_cpp_properties(mspaint WITH_EXCEPTIONS)
 add_importlibs(mspaint hhctrl comdlg32 shell32 user32 gdi32 advapi32 comctl32 msvcrt kernel32 rpcrt4 shlwapi)
 add_pch(mspaint precomp.h SOURCE)