* Sync to trunk HEAD (r53318).
[reactos.git] / base / applications / mstsc / CMakeLists.txt
index ef37c8f..a43947a 100644 (file)
@@ -1,5 +1,6 @@
 
 set_unicode()
+set_rc_compiler()
 
 list(APPEND SOURCE
     bitmap.c
@@ -23,12 +24,12 @@ list(APPEND SOURCE
     win32.c
     rdc.rc)
 
-add_executable(mstsc ${CMAKE_CURRENT_BINARY_DIR}/mstsc_precomp.h.gch ${SOURCE})
-
-add_pch(mstsc ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+add_executable(mstsc ${SOURCE})
 
 set_module_type(mstsc win32gui)
 
 add_importlibs(mstsc user32 gdi32 comctl32 ws2_32 advapi32 shell32 ole32 comdlg32 msvcrt kernel32)
 
+add_pch(mstsc precomp.h)
+
 add_cd_file(TARGET mstsc DESTINATION reactos/system32 FOR all)