[CMAKE]
[reactos.git] / base / applications / network / ftp / CMakeLists.txt
index 5f7d38b..0d74b9a 100644 (file)
@@ -1,4 +1,7 @@
-add_definitions(-D_DLL -D__USE_CRTIMP)
+
+add_definitions(
+    -D_DLL -D__USE_CRTIMP
+    -Dlint)
 
 add_executable(ftp
     cmds.c
@@ -11,7 +14,11 @@ add_executable(ftp
     ftp.rc)
 
 set_module_type(ftp win32cui)
-
 add_importlibs(ftp ws2_32 iphlpapi msvcrt kernel32)
 
-add_cab_target(ftp 1)
\ No newline at end of file
+if(MSVC)
+    target_link_libraries(ftp oldnames)
+    add_importlibs(ftp ntdll)
+endif()
+
+add_cab_target(ftp 1)