- Update to r53061
[reactos.git] / base / applications / network / ftp / CMakeLists.txt
index 0d74b9a..4898820 100644 (file)
@@ -1,7 +1,5 @@
 
-add_definitions(
-    -D_DLL -D__USE_CRTIMP
-    -Dlint)
+add_definitions(-Dlint)
 
 add_executable(ftp
     cmds.c
@@ -15,10 +13,11 @@ add_executable(ftp
 
 set_module_type(ftp win32cui)
 add_importlibs(ftp ws2_32 iphlpapi msvcrt kernel32)
+add_pch(ftp precomp.h)
 
 if(MSVC)
     target_link_libraries(ftp oldnames)
     add_importlibs(ftp ntdll)
 endif()
 
-add_cab_target(ftp 1)
+add_cd_file(TARGET ftp DESTINATION reactos/system32 FOR all)