- Update to r53061
[reactos.git] / base / applications / network / ftp / CMakeLists.txt
index a04e8d4..4898820 100644 (file)
@@ -1,3 +1,6 @@
+
+add_definitions(-Dlint)
+
 add_executable(ftp
     cmds.c
     cmdtab.c
@@ -9,5 +12,12 @@ add_executable(ftp
     ftp.rc)
 
 set_module_type(ftp win32cui)
-
 add_importlibs(ftp ws2_32 iphlpapi msvcrt kernel32)
+add_pch(ftp precomp.h)
+
+if(MSVC)
+    target_link_libraries(ftp oldnames)
+    add_importlibs(ftp ntdll)
+endif()
+
+add_cd_file(TARGET ftp DESTINATION reactos/system32 FOR all)