Synchronize with trunk.
[reactos.git] / base / applications / network / telnet / CMakeLists.txt
index 74f41d0..672a0de 100644 (file)
@@ -1,7 +1,7 @@
 
-add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)
+set_cpp(WITH_EXCEPTIONS WITH_STL)
 
-set_cpp()
+add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)
 
 add_executable(telnet
     src/ansiprsr.cpp
@@ -27,5 +27,9 @@ add_executable(telnet
 
 set_module_type(telnet win32cui)
 add_pch(telnet src/precomp.h)
-add_importlibs(telnet ws2_32 user32 msvcrt kernel32)
+add_importlibs(telnet ws2_32 user32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET telnet DESTINATION reactos/system32 FOR all)
+
+if(NOT MSVC)
+    add_compile_flags_language("-Wno-narrowing" "CXX")
+endif()