Sync with trunk r63192.
[reactos.git] / base / applications / rapps / CMakeLists.txt
index f49f70d..8fb4ea5 100644 (file)
@@ -1,6 +1,4 @@
 
-set_unicode()
-
 list(APPEND SOURCE
     aboutdlg.c
     available.c
@@ -17,19 +15,13 @@ list(APPEND SOURCE
     toolbar.c
     treeview.c
     winmain.c
-    rapps.rc)
-
-include_directories(
-    ${CMAKE_CURRENT_BINARY_DIR}
-    ${REACTOS_BINARY_DIR}/include/reactos)
+    rapps.h)
 
-set_rc_compiler()
-
-add_executable(rapps ${SOURCE})
-set_module_type(rapps win32gui)
+add_executable(rapps ${SOURCE} rapps.rc)
+set_module_type(rapps win32gui UNICODE)
 target_link_libraries(rapps uuid)
-
-add_importlibs(rapps advapi32 comctl32 gdi32 urlmon user32 shell32 shlwapi kernel32 msvcrt ntdll)
+add_importlibs(rapps advapi32 comctl32 gdi32 urlmon wininet user32 shell32 shlwapi ole32 msvcrt kernel32 ntdll)
+add_pch(rapps rapps.h SOURCE)
 add_dependencies(rapps rappsmsg)
-add_message_headers(rappsmsg.mc)
-add_cab_target(rapps 1)
+add_message_headers(ANSI rappsmsg.mc)
+add_cd_file(TARGET rapps DESTINATION reactos/system32 FOR all)