[RAPPS] CMainWindow: remove unused functions , and the globals g_MainWindow and hListView
[reactos.git] / base / applications / rapps / CMakeLists.txt
index c0f933e..ea0cf7d 100644 (file)
@@ -1,35 +1,47 @@
+project(rapps)
 
+set_cpp(WITH_RUNTIME)
 
-list(APPEND SOURCE
-    aboutdlg.c
-    available.c
-    installdlg.c
-    installed.c
-    listview.c
-    loaddlg.c
-    misc.c
-    parser.c
-    richedit.c
-    settingsdlg.c
-    splitter.c
-    statusbar.c
-    toolbar.c
-    treeview.c
-    winmain.c
-    rapps.rc)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/cryptlib)
+include_directories(include)
 
-include_directories(
-    ${CMAKE_CURRENT_BINARY_DIR}
-    ${REACTOS_BINARY_DIR}/include/reactos)
+list(APPEND SOURCE
+    aboutdlg.cpp
+    available.cpp
+    cabinet.cpp
+    gui.cpp
+    installed.cpp
+    integrity.cpp
+    loaddlg.cpp
+    misc.cpp
+    settingsdlg.cpp
+    winmain.cpp
+    unattended.cpp
+    include/rapps.h
+    include/available.h
+    include/dialogs.h
+    include/installed.h
+    include/crichedit.h
+    include/defines.h
+    include/misc.h
+    include/resource.h
+    include/rosui.h
+    include/winmain.h
+    include/unattended.h
+)
 
-set_rc_compiler()
+add_definitions(
+    -DUSE_CERT_PINNING
+    -D_ATL_NO_EXCEPTIONS)
 
-add_executable(rapps ${SOURCE})
-add_pch(rapps rapps.h)
+file(GLOB_RECURSE rapps_rc_deps res/*.*)
+add_rc_deps(rapps.rc ${rapps_rc_deps})
+add_executable(rapps ${SOURCE} rapps.rc)
 set_module_type(rapps win32gui UNICODE)
-target_link_libraries(rapps uuid)
-
-add_importlibs(rapps advapi32 comctl32 gdi32 urlmon user32 shell32 shlwapi ole32 msvcrt kernel32 ntdll)
+target_link_libraries(rapps uuid wine)
+add_importlibs(rapps advapi32 comctl32 gdi32 wininet user32 shell32 shlwapi ole32 setupapi msvcrt kernel32 ntdll)
+add_pch(rapps include/rapps.h SOURCE)
 add_dependencies(rapps rappsmsg)
 add_message_headers(ANSI rappsmsg.mc)
 add_cd_file(TARGET rapps DESTINATION reactos/system32 FOR all)