[CMAKE]
[reactos.git] / base / applications / regedit / CMakeLists.txt
index cc5ce0f..24819be 100644 (file)
@@ -1,5 +1,8 @@
 
+add_definitions(-D_DLL -D__USE_CRTIMP)
+
 set_unicode()
+set_rc_compiler()
 
 include_directories(BEFORE .)
 
@@ -7,6 +10,7 @@ list(APPEND SOURCE
     about.c
     childwnd.c
     edit.c
+    error.c
     find.c
     framewnd.c
     hexedit.c
@@ -29,3 +33,5 @@ target_link_libraries(regedit uuid)
 add_importlibs(regedit user32 gdi32 advapi32 ole32 shell32 comctl32 comdlg32 shlwapi msvcrt kernel32)
 
 #add_subdirectory(clb)
+
+add_cd_file(TARGET regedit DESTINATION reactos)