* Sync with recent trunk (r52637).
[reactos.git] / base / applications / regedit / CMakeLists.txt
index 95f51a5..9b6ae4d 100644 (file)
@@ -1,7 +1,6 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
-
 set_unicode()
+set_rc_compiler()
 
 include_directories(BEFORE .)
 
@@ -21,9 +20,7 @@ list(APPEND SOURCE
     treeview.c
     regedit.rc)
 
-add_pch(regedit ${CMAKE_CURRENT_SOURCE_DIR}/regedit.h ${SOURCE})
-
-add_executable(regedit ${CMAKE_CURRENT_BINARY_DIR}/regedit_regedit.h.gch ${SOURCE})
+add_executable(regedit ${SOURCE})
 
 set_module_type(regedit win32gui)
 
@@ -31,6 +28,8 @@ target_link_libraries(regedit uuid)
 
 add_importlibs(regedit user32 gdi32 advapi32 ole32 shell32 comctl32 comdlg32 shlwapi msvcrt kernel32)
 
+add_pch(regedit regedit.h)
+
 #add_subdirectory(clb)
 
-add_cab_target(regedit 4)
+add_cd_file(TARGET regedit DESTINATION reactos FOR all)