[SHELL32] SHChangeNotify: Add drive, remove drive (#6782)
[reactos.git] / base / applications / regedit / CMakeLists.txt
index 08f8f6c..a1d2ffc 100644 (file)
@@ -1,6 +1,10 @@
 
 include_directories(BEFORE .)
 
+if(DBG)
+    add_definitions(-D_DEBUG=1)
+endif()
+
 list(APPEND SOURCE
     about.c
     childwnd.c
@@ -16,12 +20,15 @@ list(APPEND SOURCE
     security.c
     settings.c
     treeview.c
-    regedit.rc)
+    txtproc.c
+    regedit.h)
 
-add_executable(regedit ${SOURCE})
+file(GLOB regedit_rc_deps res/*.*)
+add_rc_deps(regedit.rc ${regedit_rc_deps})
+add_executable(regedit ${SOURCE} regedit.rc)
 set_module_type(regedit win32gui UNICODE)
-target_link_libraries(regedit uuid)
-add_importlibs(regedit user32 gdi32 advapi32 ole32 shell32 comctl32 comdlg32 shlwapi msvcrt kernel32)
-add_pch(regedit regedit.h)
+target_link_libraries(regedit uuid wine)
+add_importlibs(regedit user32 gdi32 advapi32 ole32 shell32 comctl32 comdlg32 shlwapi msvcrt kernel32 ntdll)
+add_pch(regedit regedit.h SOURCE)
 add_cd_file(TARGET regedit DESTINATION reactos FOR all)
-#add_subdirectory(clb)
+add_subdirectory(clb)