[CMAKE]
[reactos.git] / base / applications / shutdown / CMakeLists.txt
index e726379..196d558 100644 (file)
@@ -1,4 +1,6 @@
 
+add_definitions(-D_DLL -D__USE_CRTIMP)
+
 list(APPEND SOURCE
     misc.c
     shutdown.c
@@ -9,5 +11,5 @@ add_executable(shutdown ${CMAKE_CURRENT_BINARY_DIR}/shutdown_precomp.h.gch ${SOU
 add_pch(shutdown ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
 
 set_module_type(shutdown win32cui)
-
 add_importlibs(shutdown advapi32 user32 msvcrt kernel32)
+add_cd_file(TARGET shutdown DESTINATION reactos/system32 FOR all)