[CMAKE]
[reactos.git] / base / applications / sndvol32 / CMakeLists.txt
index ee26494..d39b0ed 100644 (file)
@@ -1,8 +1,11 @@
 
+add_definitions(-D_DLL -D__USE_CRTIMP)
+
 set_unicode()
 
 list(APPEND SOURCE
-    misc.c
+    dialog.c
+       misc.c
     mixer.c
     sndvol32.c
     sndvol32.rc)
@@ -12,5 +15,5 @@ add_executable(sndvol32 ${CMAKE_CURRENT_BINARY_DIR}/sndvol32_sndvol32.h.gch ${SO
 add_pch(sndvol32 ${CMAKE_CURRENT_SOURCE_DIR}/sndvol32.h ${SOURCE})
 
 set_module_type(sndvol32 win32gui)
-
 add_importlibs(sndvol32 user32 advapi32 gdi32 comctl32 shell32 winmm msvcrt kernel32 ntdll)
+add_cd_file(TARGET sndvol32 DESTINATION reactos/system32)