* Sync with recent trunk (r52637).
[reactos.git] / base / applications / sndvol32 / CMakeLists.txt
index 8136543..eecfc28 100644 (file)
@@ -1,18 +1,16 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
-
 set_unicode()
 
 list(APPEND SOURCE
+    dialog.c
     misc.c
     mixer.c
     sndvol32.c
     sndvol32.rc)
 
-add_executable(sndvol32 ${CMAKE_CURRENT_BINARY_DIR}/sndvol32_sndvol32.h.gch ${SOURCE})
-
-add_pch(sndvol32 ${CMAKE_CURRENT_SOURCE_DIR}/sndvol32.h ${SOURCE})
+add_executable(sndvol32 ${SOURCE})
 
 set_module_type(sndvol32 win32gui)
 add_importlibs(sndvol32 user32 advapi32 gdi32 comctl32 shell32 winmm msvcrt kernel32 ntdll)
-add_cab_target(sndvol32 1)
+add_pch(sndvol32 sndvol32.h)
+add_cd_file(TARGET sndvol32 DESTINATION reactos/system32 FOR all)