* Sync with recent trunk (r52637).
[reactos.git] / base / applications / taskmgr / CMakeLists.txt
index 81a6a63..99c8a25 100644 (file)
@@ -1,5 +1,6 @@
 
 set_unicode()
+set_rc_compiler()
 
 list(APPEND SOURCE
     about.c
@@ -22,10 +23,9 @@ list(APPEND SOURCE
     graphctl.c
     taskmgr.rc)
 
-add_executable(taskmgr ${CMAKE_CURRENT_BINARY_DIR}/taskmgr_precomp.h.gch ${SOURCE})
-
-add_pch(taskmgr ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+add_executable(taskmgr ${SOURCE})
 
 set_module_type(taskmgr win32gui)
-
 add_importlibs(taskmgr advapi32 user32 gdi32 shell32 comctl32 msvcrt kernel32 ntdll)
+add_pch(taskmgr precomp.h)
+add_cd_file(TARGET taskmgr DESTINATION reactos/system32 FOR all)