* Sync to trunk HEAD (r53318).
[reactos.git] / base / services / eventlog / CMakeLists.txt
index 4246062..b63913d 100644 (file)
@@ -1,5 +1,8 @@
 
-include_directories(${REACTOS_BINARY_DIR}/include/reactos/idl)
+include_directories(${REACTOS_SOURCE_DIR}/include/reactos/idl
+    ${CMAKE_CURRENT_BINARY_DIR})
+
+add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/eventlogrpc.idl)
 
 set_unicode()
 
@@ -9,14 +12,16 @@ list(APPEND SOURCE
     logport.c
     eventlog.rc
     rpc.c
-    file.c)
-
-add_executable(eventlog ${CMAKE_CURRENT_BINARY_DIR}/eventlog_eventlog.h.gch ${SOURCE})
+    file.c
+    ${CMAKE_CURRENT_BINARY_DIR}/eventlogrpc_s.c)
 
-target_link_libraries(eventlog eventlogrpc ${PSEH_LIB})
+add_executable(eventlog ${SOURCE})
 
-add_pch(eventlog ${CMAKE_CURRENT_SOURCE_DIR}/eventlog.h ${SOURCE})
+if(NOT MSVC)
+    target_link_libraries(eventlog pseh)
+endif()
 
 set_module_type(eventlog win32cui)
 add_importlibs(eventlog advapi32 rpcrt4 msvcrt kernel32 ntdll)
+add_pch(eventlog eventlog.h)
 add_cd_file(TARGET eventlog DESTINATION reactos/system32 FOR all)