[TFTPD] Fix compilation, and use the #define MAX_SERVERS where needed instead of...
[reactos.git] / base / services / eventlog / CMakeLists.txt
index 1f799c7..eafc415 100644 (file)
@@ -1,9 +1,11 @@
 
 include_directories(
-    ${REACTOS_SOURCE_DIR}/include/reactos/idl
+    ${REACTOS_SOURCE_DIR}/sdk/lib/evtlib
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/subsys
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/idl
     ${CMAKE_CURRENT_BINARY_DIR})
 
-add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/eventlogrpc.idl)
+add_rpc_files(server ${REACTOS_SOURCE_DIR}/sdk/include/reactos/idl/eventlogrpc.idl)
 
 list(APPEND SOURCE
     eventlog.c
@@ -15,12 +17,13 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/eventlogrpc_s.c)
 
 add_executable(eventlog ${SOURCE} eventlog.rc)
+add_pch(eventlog eventlog.h SOURCE)
 
 if(NOT MSVC)
     target_link_libraries(eventlog ${PSEH_LIB})
 endif()
 
 set_module_type(eventlog win32cui UNICODE)
+target_link_libraries(eventlog evtlib)
 add_importlibs(eventlog advapi32 rpcrt4 msvcrt kernel32 ntdll)
-add_pch(eventlog eventlog.h SOURCE)
 add_cd_file(TARGET eventlog DESTINATION reactos/system32 FOR all)