[REACTOS] Fix 64 bit issues
[reactos.git] / base / services / tcpsvcs / CMakeLists.txt
index d3b267b..736c3fc 100644 (file)
@@ -1,5 +1,4 @@
 
-
 list(APPEND SOURCE
     tcpsvcs.c
     skelserver.c
@@ -8,15 +7,12 @@ list(APPEND SOURCE
     daytime.c
     qotd.c
     chargen.c
-    tcpsvcs.rc
-    log.c)
-
-add_executable(tcpsvcs ${SOURCE})
+    log.c
+    tcpsvcs.h)
 
+add_executable(tcpsvcs ${SOURCE} tcpsvcs.rc)
 set_module_type(tcpsvcs win32cui UNICODE)
 add_importlibs(tcpsvcs ws2_32 advapi32 msvcrt kernel32 ntdll)
-add_pch(tcpsvcs tcpsvcs.h)
-
-
+add_pch(tcpsvcs tcpsvcs.h SOURCE)
 add_cd_file(TARGET tcpsvcs DESTINATION reactos/system32 FOR all)
 add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/quotes DESTINATION reactos/system32/drivers/etc FOR all)