[CMAKE] Remove obsolete 'CMAKE_CXX_COMPILER_VERSION' checks (#2981)
[reactos.git] / base / services / tftpd / CMakeLists.txt
index 967dd15..f4bd0cb 100644 (file)
@@ -1,7 +1,9 @@
 
-add_executable(tftpd tftpd.cpp)
-
-target_link_libraries(tftpd wine)
+if(NOT MSVC)
+    add_compile_flags("-Wno-format-overflow")
+endif()
 
+add_executable(tftpd tftpd.cpp)
 set_module_type(tftpd win32cui)
-add_importlibs(tftpd advapi32 ws2_32 msvcrt kernel32 ntdll)
+add_importlibs(tftpd advapi32 ws2_32 iphlpapi msvcrt kernel32)
+add_cd_file(TARGET tftpd DESTINATION reactos/system32 FOR all)