Synchronize with trunk.
[reactos.git] / base / services / umpnpmgr / CMakeLists.txt
index d02270e..958fad2 100644 (file)
@@ -1,14 +1,21 @@
 
-set_unicode()
-
-include_directories(${REACTOS_BINARY_DIR}/include/reactos/idl)
+include_directories(${REACTOS_SOURCE_DIR}/include/reactos/idl)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
-add_executable(umpnpmgr umpnpmgr.c umpnpmgr.rc)
-target_link_libraries(umpnpmgr pnprpc wdmguid ${PSEH_LIB})
+add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/pnp.idl)
+
+
+add_executable(umpnpmgr
+    umpnpmgr.c
+    umpnpmgr.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/pnp_s.c)
+
+target_link_libraries(umpnpmgr
+    wdmguid
+    ${PSEH_LIB})
 
-set_module_type(umpnpmgr win32cui)
+set_module_type(umpnpmgr win32cui UNICODE)
 add_importlibs(umpnpmgr advapi32 rpcrt4 userenv msvcrt kernel32 ntdll)
 add_cd_file(TARGET umpnpmgr DESTINATION reactos/system32 FOR all)