[SETUP:REACTOS] Adapt the 1st-stage GUI setup to compile with the setuplib.
[reactos.git] / base / setup / reactos / CMakeLists.txt
index e01d532..0f08c1f 100644 (file)
@@ -1,6 +1,22 @@
 
-add_executable(reactos reactos.c reactos.rc)
-target_link_libraries(reactos uuid)
+include_directories(
+    ${CMAKE_CURRENT_SOURCE_DIR}
+    ${CMAKE_CURRENT_SOURCE_DIR}/../lib
+#    ${REACTOS_SOURCE_DIR}/base/setup/lib
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/zlib
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/drivers)
+
+list(APPEND SOURCE
+    drivepage.c
+    inffile.c
+    reactos.c
+    reactos.h)
+
+file(GLOB reactos_rc_deps res/*.*)
+add_rc_deps(reactos.rc ${reactos_rc_deps})
+add_executable(reactos ${SOURCE} reactos.rc)
 set_module_type(reactos win32gui UNICODE)
-add_importlibs(reactos gdi32 user32 comctl32 setupapi msvcrt kernel32 ntdll)
+add_pch(reactos reactos.h SOURCE)
+target_link_libraries(reactos uuid setuplib ext2lib vfatlib btrfslib)
+add_importlibs(reactos advapi32 gdi32 user32 comctl32 setupapi msvcrt kernel32 ntdll)
 add_cd_file(TARGET reactos DESTINATION reactos NO_CAB FOR bootcd)