* Sync to recent trunk (r52563).
[reactos.git] / base / shell / explorer / CMakeLists.txt
index 6f01f7e..14f7304 100644 (file)
@@ -10,10 +10,9 @@ set_unicode()
 
 add_definitions(
     -DWIN32
-    -D__WINDRES__
-    -D_DLL -D__USE_CRTIMP)
+    -D__WINDRES__)
 
-#add_pch(explorer ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h SOURCE)
+#add_pch(explorer precomp.h)
 include_directories(${CMAKE_CURRENT_SOURCE_DIR})
 
 list(APPEND SOURCE
@@ -53,7 +52,7 @@ list(APPEND SOURCE
     utility/window.cpp
     utility/shellbrowserimpl.cpp) #    utility/shelltests.cpp
 
-add_executable(explorer ${SOURCE}) #${CMAKE_CURRENT_BINARY_DIR}/explorer_precomp.h.gch ${SOURCE})
+add_executable(explorer ${SOURCE})
 
 set_subsystem(explorer windows)
 set_entrypoint(explorer WinMainCRTStartup)
@@ -64,14 +63,10 @@ target_link_libraries(explorer
     -lgcc
     -lmingwex
     wine
-    mingw_wmain
-    mingw_common
     uuid)
 
 add_importlibs(explorer advapi32 gdi32 user32 ws2_32 msimg32 comctl32 ole32 oleaut32 shell32 notifyhook msvcrt kernel32 ntdll)
-
 set_image_base(explorer 0x00400000)
-
 add_dependencies(explorer psdk)
 add_cd_file(TARGET explorer DESTINATION reactos FOR all)
 add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/explorer-cfg-template.xml DESTINATION reactos FOR all)