[CMAKE]
[reactos.git] / base / shell / explorer / CMakeLists.txt
index 9133234..c482f6a 100644 (file)
@@ -3,6 +3,11 @@ add_subdirectory(notifyhook)
 
 set_unicode()
 
+#NOTE : explorer doesn't follow standard c++, and so doesn't compile with stlport headers
+#I'm not willing to do it if explorer_new is hanging around.
+#jgardou
+#set_cpp()
+
 add_definitions(-DWIN32)
 add_definitions(-D__WINDRES__)
 
@@ -32,6 +37,7 @@ list(APPEND SOURCE
     taskbar/startmenu.cpp
     taskbar/traynotify.cpp
     precomp.cpp
+    explorer.rc
     services/startup.c
     services/shellservices.cpp
     desktop/desktop.cpp
@@ -54,7 +60,6 @@ target_link_libraries(explorer
     -lsupc++
     -lstdc++
     -lgcc
-    -lmingw32
     -lmingwex
     wine
     mingw_wmain
@@ -73,5 +78,8 @@ target_link_libraries(explorer
     -lmsvcrt
     -lkernel32
     -lntdll)
+       
+set_image_base(explorer 0x00400000)
 
 add_dependencies(explorer psdk buildno_header)
+add_cab_target(explorer 4)
\ No newline at end of file