* Sync with recent trunk (r52637).
[reactos.git] / base / shell / explorer / notifyhook / CMakeLists.txt
index ad94a20..b3eda1e 100644 (file)
@@ -1,10 +1,17 @@
+
 add_definitions(-D_NOTIFYHOOK_IMPL)
 
-add_library(notifyhook SHARED notifyhook.c ${CMAKE_CURRENT_SOURCE_DIR}/notifyhook.rc)
+spec2def(notifyhook.dll notifyhook.spec)
+
+list(APPEND SOURCE
+    notifyhook.c
+    notifyhook.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/notifyhook.def)
+
+add_library(notifyhook SHARED ${SOURCE})
 
 set_module_type(notifyhook win32dll)
 
-target_link_libraries(notifyhook 
-    ${CMAKE_CURRENT_SOURCE_DIR}/notifyhook.def
-    -lkernel32
-    -luser32)
\ No newline at end of file
+add_importlibs(notifyhook user32 msvcrt kernel32)
+add_importlib_target(notifyhook.spec)
+add_cd_file(TARGET notifyhook DESTINATION reactos/system32 FOR all)