[CMAKE] Get rid of the set_cpp macro
[reactos.git] / base / shell / rshell / CMakeLists.txt
index a272217..c47a121 100644 (file)
@@ -3,8 +3,6 @@ PROJECT(SHELL)
 add_definitions(
     -D_ATL_NO_EXCEPTIONS)
 
-set_cpp(WITH_RUNTIME)
-
 include_directories(
     ${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
@@ -24,7 +22,8 @@ target_link_libraries(rshell
     shellmenu
     shelldesktop
     uuid
-    wine)
+    wine
+    cpprt)
 
 add_importlibs(rshell
     browseui
@@ -40,14 +39,14 @@ add_importlibs(rshell
     kernel32
     ntdll)
 
-add_custom_command(TARGET rshell POST_BUILD 
-  COMMAND "${CMAKE_COMMAND}" -E copy 
+add_custom_command(TARGET rshell POST_BUILD
+  COMMAND "${CMAKE_COMMAND}" -E copy
      "$<TARGET_FILE:rshell>"
-     "$<TARGET_FILE_DIR:explorer>/$<TARGET_FILE_NAME:rshell>" 
+     "$<TARGET_FILE_DIR:explorer>/$<TARGET_FILE_NAME:rshell>"
   COMMENT "Copying to output directory")
 
-add_custom_command(TARGET rshell POST_BUILD 
-  COMMAND "${CMAKE_COMMAND}" -E copy 
+add_custom_command(TARGET rshell POST_BUILD
+  COMMAND "${CMAKE_COMMAND}" -E copy
      "$<TARGET_FILE:rshell>"
-     "$<TARGET_FILE_DIR:filebrowser>/$<TARGET_FILE_NAME:rshell>" 
+     "$<TARGET_FILE_DIR:filebrowser>/$<TARGET_FILE_NAME:rshell>"
   COMMENT "Copying to output directory")