[CMAKE] Introduce the atl_classes interface library
[reactos.git] / base / shell / rshell / CMakeLists.txt
index c47a121..8397a01 100644 (file)
@@ -1,11 +1,5 @@
 PROJECT(SHELL)
 
-add_definitions(
-    -D_ATL_NO_EXCEPTIONS)
-
-include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/lib/atl)
-
 spec2def(rshell.dll rshell.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -23,7 +17,8 @@ target_link_libraries(rshell
     shelldesktop
     uuid
     wine
-    cpprt)
+    cpprt
+    atl_classes)
 
 add_importlibs(rshell
     browseui