* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / base / system / services / CMakeLists.txt
index 66fefbc..c3ea514 100644 (file)
@@ -16,10 +16,10 @@ list(APPEND SOURCE
     lock.c
     rpcserver.c
     services.c
-    services.rc
+    services.h
     ${CMAKE_CURRENT_BINARY_DIR}/svcctl_s.c)
 
-add_executable(services ${SOURCE})
+add_executable(services ${SOURCE} services.rc)
 
 if(NOT MSVC)
     target_link_libraries(services ${PSEH_LIB})
@@ -27,5 +27,5 @@ endif()
 
 set_module_type(services win32gui UNICODE)
 add_importlibs(services user32 advapi32 rpcrt4 msvcrt kernel32 ntdll)
-add_pch(services services.h ${CMAKE_CURRENT_BINARY_DIR}/svcctl_s.h)
+add_pch(services services.h SOURCE)
 add_cd_file(TARGET services DESTINATION reactos/system32 FOR all)