[CMAKE]
[reactos.git] / base / system / smss / CMakeLists.txt
index 3fd548a..0e6513d 100644 (file)
@@ -1,3 +1,4 @@
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
 
 list(APPEND SOURCE
@@ -25,9 +26,13 @@ list(APPEND SOURCE
 add_executable(smss WIN32 ${CMAKE_CURRENT_BINARY_DIR}/smss_smss.h.gch ${SOURCE})
 
 target_link_libraries(smss mingw_common nt smlib)
+if(MSVC)
+    target_link_libraries(smss msvcsup)
+    set_entrypoint(smss DllMainCRTStartup)
+endif()
 
 add_pch(smss ${CMAKE_CURRENT_SOURCE_DIR}/smss.h ${SOURCE})
 
 set_module_type(smss nativecui)
 add_importlibs(smss ntdll)
-add_cab_target(smss 1)
\ No newline at end of file
+add_cd_file(TARGET smss DESTINATION reactos/system32)