Sync with trunk r63935.
[reactos.git] / boot / bootdata / packages / CMakeLists.txt
index d65a104..f9d1e84 100644 (file)
@@ -31,17 +31,13 @@ add_custom_command(
     DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/reactos.dff.dyn
 )
 
-# And now we build reactos.inf
-add_custom_command(
-    OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/reactos.inf
+add_custom_target(
+    reactos_cab_inf
     COMMAND native-cabman -C ${CMAKE_CURRENT_BINARY_DIR}/reactos.dff -L ${CMAKE_CURRENT_BINARY_DIR} -I -P ${REACTOS_SOURCE_DIR}
     DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/reactos.dff native-cabman)
 
-# reactos.cab generation will be made later (cf. CMakeMacros.cmake - create iso lists)
-add_custom_target(reactos_cab_inf DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/reactos.inf)
-
 add_cd_file(
-    TARGET reactos_cab
+    TARGET reactos_cab_inf
     FILE ${CMAKE_CURRENT_BINARY_DIR}/reactos.inf
     DESTINATION reactos
     NO_CAB FOR bootcd regtest)