[BOOTLIB] Fix the implementation of RtlAssert() ('Message' can be NULL, and fix the...
[reactos.git] / boot / environ / CMakeLists.txt
index 2a049a1..f79136c 100644 (file)
@@ -45,7 +45,7 @@ list(APPEND BOOTLIB_SOURCE
 
 if(ARCH STREQUAL "i386")
     list(APPEND BOOTLIB_ASM_SOURCE
-         #lib/arch/i386/foo.asm
+         lib/arch/i386/transfer.s
          )
     list(APPEND BOOTLIB_SOURCE
          lib/arch/i386/arch.c
@@ -70,7 +70,7 @@ endif()
 add_asm_files(bootlib_asm ${BOOTLIB_ASM_SOURCE})
 add_library(bootlib ${BOOTLIB_SOURCE} ${bootlib_asm})
 add_pch(bootlib app/bootmgr/bootmgr.h BOOTLIB_SOURCE)
-add_dependencies(bootlib bugcodes bootmsg xdk)
+add_dependencies(bootlib bugcodes asm bootmsg xdk)
 
 list(APPEND BOOTMGR_BASE_SOURCE
      app/bootmgr/efiemu.c
@@ -81,7 +81,11 @@ add_executable(bootmgfw ${BOOTMGR_BASE_SOURCE} app/bootmgr/bootmgr.rc)
 set_target_properties(bootmgfw PROPERTIES SUFFIX ".efi")
 
 if(MSVC)
-    add_target_link_flags(bootmgfw "/ignore:4078 /ignore:4254 /DRIVER /FIXED")
+    if (ARCH STREQUAL "arm")
+        add_target_link_flags(bootmgfw "/ignore:4078 /ignore:4254 /DRIVER")
+    else()
+        add_target_link_flags(bootmgfw "/ignore:4078 /ignore:4254 /DRIVER /FIXED")
+    endif()
 else()
     add_target_link_flags(bootmgfw "-Wl,--strip-all,--exclude-all-symbols")
 endif()
@@ -108,9 +112,17 @@ add_dependencies(bootmgfw asm bugcodes)
 
 list(APPEND ROSLOAD_BASE_SOURCE
      app/rosload/rosload.c
+     app/rosload/roslogo.c
      )
 
-add_executable(rosload ${ROSLOAD_BASE_SOURCE})
+if(ARCH STREQUAL "i386")
+    list(APPEND ROSLOAD_ASM_SOURCE
+         app/rosload/i386/osxfera.s
+         )
+endif()
+
+add_asm_files(rosload_asm ${ROSLOAD_ASM_SOURCE})
+add_executable(rosload ${ROSLOAD_BASE_SOURCE} ${rosload_asm})
 set_target_properties(rosload PROPERTIES SUFFIX ".efi")
 
 if(MSVC)