[CMAKE]
[reactos.git] / dll / 3rdparty / dxtn / CMakeLists.txt
index cf273d3..dfdaa31 100644 (file)
@@ -1,18 +1,19 @@
 
 add_definitions(-D_DLL -D__USE_CRTIMP)
 
-spec2def(dxtn ${CMAKE_CURRENT_SOURCE_DIR}/dxtn.spec ${CMAKE_CURRENT_BINARY_DIR}/dxtn.def)
+spec2def(dxtn.dll dxtn.spec)
 
 add_library(dxtn SHARED
     fxt1.c
     dxtn.c
     wrapper.c
-    texstore.c)
+    texstore.c
+    ${CMAKE_CURRENT_BINARY_DIR}/dxtn.def)
 
 set_entrypoint(dxtn 0)
 
-target_link_libraries(dxtn ${CMAKE_CURRENT_BINARY_DIR}/dxtn.def)
-
 add_importlibs(dxtn msvcrt)
 
-add_dependencies(dxtn dxtn_def psdk buildno_header)
+add_dependencies(dxtn psdk buildno_header)
+
+add_cab_target(dxtn 1)